summaryrefslogtreecommitdiff
path: root/gnu/packages/gps.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2017-04-03 00:13:06 +0200
committerLudovic Courtès <ludo@gnu.org>2017-04-03 00:13:06 +0200
commit2a0d5de5a9decd785b22dafa69aae5320231f1b7 (patch)
tree6c532e278025fb46a94f4cb3c3a68063b7011fe1 /gnu/packages/gps.scm
parent41f6d18fb6ae7adebe72793c625ad4574991fa6d (diff)
parent245575eaf33801753ac8290e077c4397b2568540 (diff)
downloadguix-patches-2a0d5de5a9decd785b22dafa69aae5320231f1b7.tar
guix-patches-2a0d5de5a9decd785b22dafa69aae5320231f1b7.tar.gz
Merge branch 'core-updates'
Diffstat (limited to 'gnu/packages/gps.scm')
-rw-r--r--gnu/packages/gps.scm5
1 files changed, 4 insertions, 1 deletions
diff --git a/gnu/packages/gps.scm b/gnu/packages/gps.scm
index bc0f3ed115..0a9038b7a4 100644
--- a/gnu/packages/gps.scm
+++ b/gnu/packages/gps.scm
@@ -50,7 +50,10 @@
(arguments
`(#:configure-flags
'("--with-zlib=system"
- "CXXFLAGS=-std=gnu++11")
+ ;; XXX Use -fPIC to work around build problems with Qt, GCC 5, and
+ ;; recent binutils:
+ ;; https://codereview.qt-project.org/#/c/111787/
+ "CXXFLAGS=-std=gnu++11 -fPIC")
#:phases
(modify-phases %standard-phases
(add-before 'configure 'pre-configure