summaryrefslogtreecommitdiff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-06-11 10:25:30 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-06-11 10:25:30 +0100
commitd346f392eee3fa7fa78d22b687ada874dc5e5ade (patch)
treed4dc518e6b1d6d4ff5376ec2a25cb18313d34eda /gnu/packages/golang.scm
parentb8b30d404161e5e5aa73b2baa5df4c100244112d (diff)
downloadguix-patches-d346f392eee3fa7fa78d22b687ada874dc5e5ade.tar
guix-patches-d346f392eee3fa7fa78d22b687ada874dc5e5ade.tar.gz
gnu: go-github-com-sergi-go-diff: Move to golang-xyz.
* gnu/packages/golang.scm (go-github-com-sergi-go-diff): Move from here ... * gnu/packages/golang-xyz.scm: ... to here. Change-Id: If722317a42006e3bef4462b5a6fe4c0f434bd5d2
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm30
1 files changed, 0 insertions, 30 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 9bf441a938..e090bc1210 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -6961,36 +6961,6 @@ stripped.")
can be used almost directly in Go source code.")
(license license:expat)))
-(define-public go-github-com-sergi-go-diff
- (package
- (name "go-github-com-sergi-go-diff")
- (version "1.2.0")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/sergi/go-diff")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "0cbj8nshllq102iiav0k1s01b8gwbkzj674g71n938qqna32y2pa"))))
- (build-system go-build-system)
- (arguments
- `(#:import-path "github.com/sergi/go-diff/diffmatchpatch"
- #:unpack-path "github.com/sergi/go-diff"))
- (native-inputs
- (list go-github-com-stretchr-testify))
- (home-page "https://github.com/sergi/go-diff/")
- (synopsis "Algorithms to perform operations for synchronizing plain text")
- (description "@code{go-diff} offers algorithms to perform operations required for
-synchronizing plain text:
-@itemize
-@item compare two texts and return their differences
-@item perform fuzzy matching of text
-@item apply patches onto text
-@end itemize\n")
- (license license:expat)))
-
(define-public go-github-com-muesli-reflow-wordwrap
(package
(name "go-github-com-muesli-reflow-wordwrap")