summaryrefslogtreecommitdiff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorPier-Hugues Pellerin <ph@heykimo.com>2022-04-17 08:31:26 -0400
committerLudovic Courtès <ludo@gnu.org>2022-04-29 14:57:03 +0200
commit65e3de5cce7b921f07515b633ab9ac7199a2598f (patch)
tree481c53cc5d73db31699f5a6216df348929ca9ce2 /gnu/packages/golang.scm
parent391dc965299de6b2313e0f2c6c52ceef3294e55f (diff)
downloadguix-patches-65e3de5cce7b921f07515b633ab9ac7199a2598f.tar
guix-patches-65e3de5cce7b921f07515b633ab9ac7199a2598f.tar.gz
gnu: go: Update to 1.17.9.
go 1.17.9 (released 2022-04-12) includes security fixes to the crypto/elliptic and encoding/pem packages, as well as bug fixes to the linker and runtime. * gnu/packages/golang.scm (go-1.17): Update to 1.17.9. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 60ba76b2ea..5cf925f199 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -626,7 +626,7 @@ in the style of communicating sequential processes (@dfn{CSP}).")
(package
(inherit go-1.16)
(name "go")
- (version "1.17.8")
+ (version "1.17.9")
(source
(origin
(method git-fetch)
@@ -636,7 +636,7 @@ in the style of communicating sequential processes (@dfn{CSP}).")
(file-name (git-file-name name version))
(sha256
(base32
- "05qfs17wddxmmi349g9ci12w9fjb5vbss6qpjc4qzgqzznqf0ycy"))))
+ "02l6gxn738kam1niy2nl2wpsbzl4x87h2wik6hd3py19kq4z2flw"))))
(outputs '("out" "tests")) ; 'tests' contains distribution tests.
(arguments
`(#:modules ((ice-9 match)