summaryrefslogtreecommitdiff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-12-21 18:20:38 +0200
committerEfraim Flashner <efraim@flashner.co.il>2021-12-21 18:24:00 +0200
commit7ccfec3065ffec59b5d285ec6b1dde06ce891781 (patch)
tree206c172dc474146e697569eb78eb16e3affeec88 /gnu/packages/golang.scm
parent3b3bef3e4e3a8f38e8686262cd12e1786a9ac2b0 (diff)
downloadguix-patches-7ccfec3065ffec59b5d285ec6b1dde06ce891781.tar
guix-patches-7ccfec3065ffec59b5d285ec6b1dde06ce891781.tar.gz
gnu: go-1.17: Simplify native-inputs.
* gnu/packages/golang.scm (go-1.17)[native-inputs]: Remove unnecessary quoting.
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm10
1 files changed, 5 insertions, 5 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 71596a9a54..f03e9cc6f3 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -798,11 +798,11 @@ in the style of communicating sequential processes (@dfn{CSP}).")
"README.md" "SECURITY.md"))))))))
(inputs (alist-delete "gcc:lib" (package-inputs go-1.16)))
(native-inputs
- `(,@(if (not (member (%current-system) (package-supported-systems go-1.4)))
- ;; gccgo-10.4, 11.3 and lower has a bug which causes bootstrapping
- ;; to fail. Use go-1.16 until we have a newer version available.
- (alist-replace "go" (list go-1.16) (package-native-inputs go-1.16))
- (package-native-inputs go-1.16))))))
+ (if (not (member (%current-system) (package-supported-systems go-1.4)))
+ ;; gccgo-10.4, 11.3 and lower has a bug which causes bootstrapping
+ ;; to fail. Use go-1.16 until we have a newer version available.
+ (alist-replace "go" (list go-1.16) (package-native-inputs go-1.16))
+ (package-native-inputs go-1.16)))))
(define-public go go-1.14)