summaryrefslogtreecommitdiff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorRaghav Gururajan <rg@raghavgururajan.name>2021-05-24 17:58:40 -0400
committerRaghav Gururajan <rg@raghavgururajan.name>2021-07-07 09:41:20 -0400
commitdb8d15924c5b71e86bfafbc3b80e50a91bae1999 (patch)
treeb354b5a132c9d663c832628dd629560f10c93f5c /gnu/packages/golang.scm
parent084dcd2708565a403b3ea1bc550e13aa7097bee0 (diff)
downloadguix-patches-db8d15924c5b71e86bfafbc3b80e50a91bae1999.tar
guix-patches-db8d15924c5b71e86bfafbc3b80e50a91bae1999.tar.gz
gnu: Add go-github-com-op-go-logging.
* gnu/packages/golang.scm (go-github-com-op-go-logging): New variable.
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 81815f9c6b..adfe7995f3 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -74,6 +74,32 @@
#:use-module (ice-9 match)
#:use-module (srfi srfi-1))
+(define-public go-github-com-op-go-logging
+ (package
+ (name "go-github-com-op-go-logging")
+ (version "1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url "https://github.com/op/go-logging")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "01a6lkpj5p82gplddh55az194s9y3014p4j8x4zc8yv886z9c8gn"))))
+ (build-system go-build-system)
+ (arguments
+ `(#:tests? #f ; ERROR: incorrect callpath: String.rec...a.b.c.Info.
+ #:import-path "github.com/op/go-logging"))
+ (home-page "https://github.com/op/go-logging")
+ (synopsis "Go logging library")
+ (description "Go-Logging implements a logging infrastructure for Go. Its
+output format is customizable and supports different logging backends like
+syslog, file and memory. Multiple backends can be utilized with different log
+levels per backend and logger.")
+ (license license:bsd-3)))
+
(define-public go-github-com-operatorfoundation-shapeshifter-ipc
(package
(name "go-github-com-operatorfoundation-shapeshifter-ipc")