summaryrefslogtreecommitdiff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorGuix Together <jgart@dismail.de>2021-08-30 12:40:38 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-08-30 14:55:51 -0400
commitcc71a54e9f900e905192f794c7bc5346c445e651 (patch)
tree40dd9acc4f65763cb9337422bcc73812e818932d /gnu/packages/golang.scm
parentff80e775dcea56be4d234b96e3b234364b435547 (diff)
downloadguix-patches-cc71a54e9f900e905192f794c7bc5346c445e651.tar
guix-patches-cc71a54e9f900e905192f794c7bc5346c445e651.tar.gz
gnu: Add go-github-com-gdamore-tcell-v2.
* gnu/packages/golang.scm (go-github-com-gdamore-tcell-v2): New variable. Co-authored-by: Arun Isaac <arunisaac@systemreboot.net> Co-authored-by: Brice Waegeneire <brice@waegenei.re> Co-authored-by: jgart <jgart@dismail.de> Co-authored-by: Julien Lepiller <julien@lepiller.eu> Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index aed7025f51..b6e8b84749 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -5257,6 +5257,37 @@ formatting. It also favors portability, and includes support for all POSIX
systems.")
(license license:asl2.0))))
+(define-public go-github-com-gdamore-tcell-v2
+ (package
+ (inherit go-github-com-gdamore-tcell)
+ (name "go-github-com-gdamore-tcell")
+ (version "2.3.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/gdamore/tcell")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0ypbl5080q9sd3irad8mv7zlg4242i8pmg5xyhbyq95kymwibaid"))))
+ (arguments
+ `(#:import-path "github.com/gdamore/tcell/v2"
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'reset-gzip-timestamps 'make-files-writable
+ (lambda* (#:key outputs #:allow-other-keys)
+ ;; Make sure .gz files are writable so that the
+ ;; 'reset-gzip-timestamps' phase can do its work.
+ (let ((out (assoc-ref outputs "out")))
+ (for-each make-file-writable
+ (find-files out "\\.gz$"))))))))
+ (propagated-inputs
+ `(("go-golang-org-x-term" ,go-golang-org-x-term)
+ ("go-golang-org-x-sys" ,go-golang-org-x-sys)
+ ,@(package-inputs go-github-com-gdamore-tcell)))))
+
(define-public go-github-com-mattn-go-shellwords
(let ((commit "2444a32a19f450fabaa0bb3e96a703f15d9a97d2")
(version "1.0.5")