summaryrefslogtreecommitdiff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorSarah Morgensen <iskarian@mgsn.dev>2021-08-14 15:47:36 -0400
committerLeo Famulari <leo@famulari.name>2021-07-27 12:34:56 -0400
commit74bc8e59df6e54bf325ac5e5902106f82a282ae8 (patch)
treedaffc0553dd9c0d515c03e3dc72c8e265f1a46a5 /gnu/packages/golang.scm
parentc5b06d8f79fa78a99002fe5f1581645e67650650 (diff)
downloadguix-patches-74bc8e59df6e54bf325ac5e5902106f82a282ae8.tar
guix-patches-74bc8e59df6e54bf325ac5e5902106f82a282ae8.tar.gz
gnu: go-1.14: Fix test failure with GCC 9+.
With GCC 9+, go-1.14 fails a test when the gold linker is not available (https://github.com/golang/go/issues/39157). Backport the fix for that from https://github.com/golang/go/commit/4ec4a79. This is a followup to the 'master -> core-updates-frozen' merge in c4133c43c7cfe2476ebfae87f9e4d10d96de9bc7, which accidentally dropped this commit (2818c66e93c4803de1d9fb8fbc11ccc9fa6a1859) due to the code in question being moved to another part of the file on the master branch. Reported on #guix by iskarian: <https://logs.guix.gnu.org/guix/2021-08-14.log#214343> * gnu/packages/golang.scm (go-1.14)[arguments]<#:phases>{prebuild}: Fix test failure with GCC 9+. Signed-off-by: Leo Famulari <leo@famulari.name>
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm5
1 files changed, 5 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index c4122f961e..028a666963 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -307,6 +307,11 @@ in the style of communicating sequential processes (@dfn{CSP}).")
(("/bin/pwd") (which "pwd"))
(("/bin/sh") (which "sh")))
+ ;; Backport fix for go-1.14 with GCC 9+
+ ;; https://github.com/golang/go/issues/39157
+ (substitute* "cmd/go/note_test.go"
+ (("cannot find 'ld'") "cannot find [‘']ld[’']"))
+
;; Add libgcc to runpath
(substitute* "cmd/link/internal/ld/lib.go"
(("!rpath.set") "true"))