summaryrefslogtreecommitdiff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-06-24 22:11:29 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2018-06-26 02:17:02 +0200
commit188b88e2449da0f96aa3796068d376527526160d (patch)
tree5b27552d8b677305a631b97f6963e36bcba1db8f /gnu/packages/golang.scm
parent2a49f7ad5106778df5ef69197ca0dad4e8a16185 (diff)
downloadguix-patches-188b88e2449da0f96aa3796068d376527526160d.tar
guix-patches-188b88e2449da0f96aa3796068d376527526160d.tar.gz
gnu: go@1.9: Return #t from all phases.
* gnu/packages/golang.scm (go-1.9)[arguments]: Substitute INVOKE for SYSTEM*. Return #t rather than undefined from phases.
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm5
1 files changed, 3 insertions, 2 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index ec574acdda..3640d7640b 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -344,7 +344,7 @@ in the style of communicating sequential processes (@dfn{CSP}).")
(setenv "GOROOT" (dirname (getcwd)))
(setenv "GOROOT_FINAL" output)
(setenv "CGO_ENABLED" "1")
- (zero? (system* "sh" "all.bash")))))
+ (invoke "sh" "all.bash"))))
(replace 'install
;; TODO: Most of this could be factorized with Go 1.4.
@@ -375,7 +375,8 @@ in the style of communicating sequential processes (@dfn{CSP}).")
'("README.md" "CONTRIBUTORS" "AUTHORS" "PATENTS"
"LICENSE" "VERSION" "CONTRIBUTING.md" "robots.txt"))
- (copy-recursively "../" output))))))))
+ (copy-recursively "../" output)
+ #t)))))))
(native-inputs
`(("go" ,go-1.4)
,@(package-native-inputs go-1.4)))