summaryrefslogtreecommitdiff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorRouby Pierre-Antoine <pierre-antoine.rouby@inria.fr>2018-05-15 15:24:42 +0200
committerLudovic Courtès <ludo@gnu.org>2018-05-23 13:53:14 +0200
commitc4230cda090b8a4d96c195173f968c7a603d6d36 (patch)
tree02120f47b3b5ca968c23c3ab8b7fb0d971c84d42 /gnu/packages/golang.scm
parent0972411a5712e7d2b40f6a5fcca0c99a3d9534cb (diff)
downloadguix-patches-c4230cda090b8a4d96c195173f968c7a603d6d36.tar
guix-patches-c4230cda090b8a4d96c195173f968c7a603d6d36.tar.gz
gnu: Add go-github-com-jpillora-backoff.
* gnu/packages/golang.scm (go-github-com-jpillora-backoff): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 01e59983fe..e4caf82562 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -1385,3 +1385,29 @@ constraints, and verifying versions against a set of constraints. It can sort
a collection of versions properly, handles prerelease/beta versions, can
increment versions.")
(license license:mpl2.0))))
+
+(define-public go-github-com-jpillora-backoff
+ (let ((commit
+ "06c7a16c845dc8e0bf575fafeeca0f5462f5eb4d")
+ (revision "0"))
+ (package
+ (name "go-github-com-jpillora-backoff")
+ (version (git-version "0.0.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/jpillora/backoff.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0xhvxr7bm47czdc5hy3kl508z3y4j91i2jm7vg774i52zych6k4l"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/jpillora/backoff"))
+ (home-page "https://github.com/jpillora/backoff")
+ (synopsis "Simple exponential backoff counter in Go")
+ (description "This package is a simple exponential backoff counter in
+Go.")
+ (license license:expat))))