summaryrefslogtreecommitdiff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorPierre Neidhardt <ambrevar@gmail.com>2018-06-22 17:39:23 +0200
committerPierre Neidhardt <ambrevar@gmail.com>2018-07-22 21:23:13 +0200
commit3291be815b3b31223fd190204e5c56ffb370c4a4 (patch)
treeaaa0142cf894394094a530f26934a0f95e80c104 /gnu/packages/golang.scm
parente968542d298a3eaf1a8811a91463b1589589fcb3 (diff)
downloadguix-patches-3291be815b3b31223fd190204e5c56ffb370c4a4.tar
guix-patches-3291be815b3b31223fd190204e5c56ffb370c4a4.tar.gz
gnu: Add go-github-com-mattn-go-isatty.
* gnu/packages/golang.scm (go-github-com-mattn-go-isatty): New variable.
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 92ce504c52..26f9fda14d 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -11,6 +11,7 @@
;;; Copyright © 2018 Christopher Baines <mail@cbaines.net>
;;; Copyright © 2018 Tomáš Čech <sleep_walker@gnu.org>
;;; Copyright © 2018 Pierre-Antoine Rouby <pierre-antoine.rouby@inria.fr>
+;;; Copyright © 2018 Pierre Neidhardt <ambrevar@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1975,3 +1976,29 @@ which satisfies the cron expression.")
"This package provides a Go library for encode and decode YAML
values.")
(license license:asl2.0))))
+
+(define-public go-github-com-mattn-go-isatty
+ (let ((commit "6ca4dbf54d38eea1a992b3c722a76a5d1c4cb25c")
+ (revision "0"))
+ (package
+ (name "go-github-com-mattn-go-isatty")
+ (version (git-version "0.0.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/mattn/go-isatty")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0zs92j2cqaw9j8qx1sdxpv3ap0rgbs0vrvi72m40mg8aa36gd39w"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/mattn/go-isatty"))
+ (home-page "https://github.com/mattn/go-isatty")
+ (synopsis "Provide @code{isatty} for Golang")
+ (description "This package provides @code{isatty}, a Go module that can
+tell you whether a file descriptor points to a terminal and the type of the
+terminal.")
+ (license license:expat))))