summaryrefslogtreecommitdiff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorSarah Morgensen <iskarian@mgsn.dev>2021-09-09 17:50:09 -0700
committerLeo Famulari <leo@famulari.name>2021-09-09 21:34:50 -0400
commitf161f111e0692da4103196a351081a6396f3834a (patch)
treef21873d146ac347b460b524b2762288152c70147 /gnu/packages/golang.scm
parent4e1adbc3b0b6694785476f4f01fbd8004fdfb5a3 (diff)
downloadguix-patches-f161f111e0692da4103196a351081a6396f3834a.tar
guix-patches-f161f111e0692da4103196a351081a6396f3834a.tar.gz
gnu: go-github-com-urfave-cli: Fix tests when building with Go 1.17.
* gnu/packages/patches/go-github-com-urfave-cli-fix-tests.patch: New file. * gnu/local.mk (dist_patch_DATA): Register it. * gnu/packages/golang.scm (go-github-com-urfave-cli)[origin]: Apply it. Signed-off-by: Leo Famulari <leo@famulari.name>
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm3
1 files changed, 2 insertions, 1 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index b08796e22a..2d0bbdb30d 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -4976,7 +4976,8 @@ as conversion to and from @command{net.Addr}.")
(file-name (git-file-name name version))
(sha256
(base32
- "10mcnvi5qmn00vpyk6si8gjka7p654wr9hac4zc9w5h3ickhvbdc"))))
+ "10mcnvi5qmn00vpyk6si8gjka7p654wr9hac4zc9w5h3ickhvbdc"))
+ (patches (search-patches "go-github-com-urfave-cli-fix-tests.patch"))))
(build-system go-build-system)
(arguments
'(#:import-path "github.com/urfave/cli"))