summaryrefslogtreecommitdiff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorRaghav Gururajan <rg@raghavgururajan.name>2021-05-22 19:15:06 -0400
committerRaghav Gururajan <rg@raghavgururajan.name>2021-07-07 09:41:18 -0400
commitd03fa9aa926266fcc4652a6ce14b47f2887815a5 (patch)
tree815dcbee202ce51ec3d797b60e3e218493ec95dc /gnu/packages/golang.scm
parenta329bc7e0c61d6eef7b9475c847c2eb8200bfe32 (diff)
downloadguix-patches-d03fa9aa926266fcc4652a6ce14b47f2887815a5.tar
guix-patches-d03fa9aa926266fcc4652a6ce14b47f2887815a5.tar.gz
gnu: Add go-github-com-rakyll-statik.
* gnu/packages/golang.scm (go-github-com-rakyll-statik): New variable. Co-authored-by: jgart <jgart@dismail.de>
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 0318918a37..6622302a71 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -27,6 +27,8 @@
;;; Copyright © 2021 Guillaume Le Vaillant <glv@posteo.net>
;;; Copyright © 2021 Sharlatan Hellseher <sharlatanus@mgail.com>
;;; Copyright © 2021 Sarah Morgensen <iskarian@mgsn.dev>
+;;; Copyright © 2021 Raghav Gururajan <rg@raghavgururajan.name>
+;;; Copyright © 2021 jgart <jgart@dismail.de>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -72,6 +74,29 @@
#:use-module (ice-9 match)
#:use-module (srfi srfi-1))
+(define-public go-github-com-rakyll-statik
+ (package
+ (name "go-github-com-rakyll-statik")
+ (version "0.1.7")
+ (source
+ (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url "https://github.com/rakyll/statik")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0y0kbzma55vmyqhyrw9ssgvxn6nw7d0zg72a7nz8vp1zly4hs6va"))))
+ (build-system go-build-system)
+ (arguments
+ `(#:import-path "github.com/rakyll/statik"))
+ (home-page "https://github.com/rakyll/statik/")
+ (synopsis "Embed files into a Go executable")
+ (description "Statik allows you to embed a directory of static files into
+your Go binary to be later served from an http.FileSystem.")
+ (license license:asl2.0)))
+
;; According to https://golang.org/doc/install/gccgo, gccgo-4.8.2 includes a
;; complete go-1.1.2 implementation, gccgo-4.9 includes a complete go-1.2
;; implementation, and gccgo-5 a complete implementation of go-1.4. Ultimately