summaryrefslogtreecommitdiff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorCollin J. Doering <collin@rekahsoft.ca>2021-12-26 22:06:06 -0500
committerLudovic Courtès <ludo@gnu.org>2022-01-01 15:10:12 +0100
commit5304802f7e9409c347076adf3a76ee1a35465d4a (patch)
treecdf127b7e2c14a33a8b4e3f9bfb1b5a5550bd2d5 /gnu/packages/golang.scm
parentbf87faff3c61de97040bcef6ef77e507f400032a (diff)
downloadguix-patches-5304802f7e9409c347076adf3a76ee1a35465d4a.tar
guix-patches-5304802f7e9409c347076adf3a76ee1a35465d4a.tar.gz
gnu: Add go-github-com-go-libsecret
* gnu/packages/golang.scm (go-github-com-go-libsecret): New variable. Co-authored-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 22569828f2..c2f413036d 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -8895,3 +8895,31 @@ be useful for other network applications.")
encrypting JSON Web Tokens (JWT). It relies only on the standard library.")
(home-page "https://github.com/dvsekhvalnov/jose2go")
(license license:expat)))
+
+(define-public go-github-com-go-libsecret
+ (let ((commit "a6f4afe4910cad8688db3e0e9b9ac92ad22d54e1")
+ (revision "0"))
+ (package
+ (name "go-github-com-go-libsecret")
+ (version "5.0.1")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/gsterjov/go-libsecret")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "09zaiadnll83vs22ib89agg7anj0blw5fywvmckxllsgif6ak6v7"))))
+ (build-system go-build-system)
+ (native-inputs
+ (list go-github-com-godbus-dbus))
+ (arguments
+ '(#:import-path "github.com/gsterjov/go-libsecret"
+ #:phases %standard-phases))
+ (synopsis "Manage secrets via the \"Secret Service\" DBus API")
+ (description
+ "This native Go library manages secrets via the freedesktop.org
+\"Secret Service\" DBus interface.")
+ (home-page "https://github.com/gsterjov/go-libsecret")
+ (license license:expat))))