summaryrefslogtreecommitdiff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorArun Isaac <arunisaac@systemreboot.net>2021-07-09 12:34:02 +0530
committerArun Isaac <arunisaac@systemreboot.net>2021-08-01 19:20:26 +0530
commitedaea8d2ace2745c0d2ecc1429928905815a4439 (patch)
tree481751f82cf5ad0a3d5e092477b1ec6a56d784a4 /gnu/packages/golang.scm
parent344460bab44ec3473877089983e4a5b518b9c9d5 (diff)
downloadguix-patches-edaea8d2ace2745c0d2ecc1429928905815a4439.tar
guix-patches-edaea8d2ace2745c0d2ecc1429928905815a4439.tar.gz
gnu: Add go-github-com-dustin-go-humanize.
* gnu/packages/golang.scm (go-github-com-dustin-go-humanize): New variable.
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index cbce7bec41..972989c84f 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -8249,3 +8249,27 @@ Go.")
the External Data Representation (XDR) standard protocol as specified in RFC
4506 (obsoletes RFC 1832 and RFC 1014) in pure Go.")
(license license:isc)))
+
+(define-public go-github-com-dustin-go-humanize
+ (package
+ (name "go-github-com-dustin-go-humanize")
+ (version "1.0.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/dustin/go-humanize")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1kqf1kavdyvjk7f8kx62pnm7fbypn9z1vbf8v2qdh3y7z7a0cbl3"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/dustin/go-humanize"))
+ (home-page "https://github.com/dustin/go-humanize")
+ (synopsis "Humane unit formatter")
+ (description "@code{go-humanize} provides formatters for units to human
+friendly sizes. It converts boring ugly numbers to human-friendly strings and
+back.")
+ (license license:expat)))