summaryrefslogtreecommitdiff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorMathieu Othacehe <othacehe@gnu.org>2021-10-18 14:33:09 +0000
committerMathieu Othacehe <othacehe@gnu.org>2021-10-18 14:37:26 +0000
commite486b2b674badc80627b11077b7df2ac1cab92d8 (patch)
tree5909547a69c4b185b878c8f0fe8152f1c01fef04 /gnu/packages/golang.scm
parent0df1eb029efe5ebe3f02e36fa650cae4aaba89ec (diff)
parent88badc074a5dbebf80115918cf6c0009075154d2 (diff)
downloadguix-patches-e486b2b674badc80627b11077b7df2ac1cab92d8.tar
guix-patches-e486b2b674badc80627b11077b7df2ac1cab92d8.tar.gz
Merge remote-tracking branch 'signed/master' into core-updates
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm25
1 files changed, 24 insertions, 1 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 51bd9686ec..fac3186777 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -30,6 +30,7 @@
;;; Copyright © 2021 Raghav Gururajan <rg@raghavgururajan.name>
;;; Copyright © 2021 jgart <jgart@dismail.de>
;;; Copyright © 2021 Bonface Munyoki Kilyungi <me@bonfacemunyoki.com>
+;;; Copyright © 2021 Chadwain Holness <chadwainholness@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -2690,7 +2691,7 @@ time.")
(origin
(method git-fetch)
(uri (git-reference
- (url "https://go.googlesource.com/x/mod")
+ (url "https://github.com/golang/mod")
(commit commit)))
(file-name (git-file-name name version))
(sha256
@@ -8827,3 +8828,25 @@ line. @code{csvdiff} supports
JSON for post-processing
@end itemize")
(license license:expat)))
+
+(define-public go-gopkg-in-djherbis-times-v1
+ (package
+ (name "go-gopkg-in-djherbis-times-v1")
+ (version "1.5.0")
+ (home-page "https://gopkg.in/djherbis/times.v1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url home-page)
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1xvl3rgjif5yf62p16yk05kxrsmzhz1kkqisvw4k02svzq10qbfy"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "gopkg.in/djherbis/times.v1"))
+ (synopsis "Go library for getting file times")
+ (description
+ "Provides a platform-independent way to get atime, mtime, ctime and btime for files.")
+ (license license:expat)))