summaryrefslogtreecommitdiff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorRaghav Gururajan <rg@raghavgururajan.name>2021-05-24 18:53:00 -0400
committerRaghav Gururajan <rg@raghavgururajan.name>2021-07-07 09:41:20 -0400
commitd1f4ace68ef58a54398d7378be34f35ed2a5d1a7 (patch)
tree5081874f61f6aeab517c6e28380e82907e4eb301 /gnu/packages/golang.scm
parent314f505f2c361c4e9e252f9e526294fe583bf81c (diff)
downloadguix-patches-d1f4ace68ef58a54398d7378be34f35ed2a5d1a7.tar
guix-patches-d1f4ace68ef58a54398d7378be34f35ed2a5d1a7.tar.gz
gnu: Add go-github-com-deckarep-golang-set.
* gnu/packages/golang.scm (go-github-com-deckarep-golang-set): New variable.
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 309af40503..0d8239675e 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -74,6 +74,28 @@
#:use-module (ice-9 match)
#:use-module (srfi srfi-1))
+(define-public go-github-com-deckarep-golang-set
+ (package
+ (name "go-github-com-deckarep-golang-set")
+ (version "1.7.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url "https://github.com/deckarep/golang-set")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0y64c0p6a7ww5jp6adm6fm97vsni86njw8wkwxfmciy466vhl0lf"))))
+ (build-system go-build-system)
+ (arguments
+ `(#:import-path "github.com/deckarep/golang-set"))
+ (home-page "https://github.com/deckarep/golang-set")
+ (synopsis "Set type for Go")
+ (description "Set is the set collection for the Go language.")
+ (license license:expat)))
+
(define-public go-github-com-blanu-dust
(package
(name "go-github-com-blanu-dust")