summaryrefslogtreecommitdiff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorraingloom <raingloom@riseup.net>2021-11-02 06:46:57 +0000
committerRicardo Wurmus <rekado@elephly.net>2021-12-01 17:03:34 +0100
commit7e4b418733b67ee9d40091a3d1d7fef30bd84933 (patch)
tree81618ad034a30eb3fb6a4ba57ad369f8239465f1 /gnu/packages/golang.scm
parentb7e774a8288dd0e5c3a9584efdb7c31ee371791e (diff)
downloadguix-patches-7e4b418733b67ee9d40091a3d1d7fef30bd84933.tar
guix-patches-7e4b418733b67ee9d40091a3d1d7fef30bd84933.tar.gz
gnu: Rename go-github-com-cheggaaa-pb to go-github-com-cheggaaa-pb-v3.
* gnu/packages/golang.scm (go-github-com-cheggaaa-pb): Rename this variable... (go-github-com-cheggaaa-pb-v3): ...to this variable. (go-github-com-cheggaaa-pb): New variable for deprecated package. Co-authored-by: Ricardo Wurmus <rekado@elephly.net>
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm7
1 files changed, 5 insertions, 2 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index d7f8fcdc3a..1fbe33929d 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -7945,9 +7945,9 @@ error messages.")
inspired by the causal messaging system in the Pony programming language.")
(license license:expat))))
-(define-public go-github-com-cheggaaa-pb
+(define-public go-github-com-cheggaaa-pb-v3
(package
- (name "go-github-com-cheggaaa-pb")
+ (name "go-github-com-cheggaaa-pb-v3")
(version "3.0.8")
(source
(origin
@@ -7978,6 +7978,9 @@ inspired by the causal messaging system in the Pony programming language.")
the terminal.")
(license license:bsd-3)))
+(define-public go-github-com-cheggaaa-pb
+ (deprecated-package "go-github-com-cheggaaa-pb" go-github-com-cheggaaa-pb-v3))
+
(define-public go-github-com-gologme-log
;; this is the same as v1.2.0, only the LICENSE file changed
(let ((commit "720ba0b3ccf0a91bc6018c9967a2479f93f56a55"))