summaryrefslogtreecommitdiff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorRaghav Gururajan <rg@raghavgururajan.name>2021-05-24 19:12:27 -0400
committerRaghav Gururajan <rg@raghavgururajan.name>2021-07-07 09:41:21 -0400
commit19f3b7c7b8ccd157999d004f0054c9e6217db5c0 (patch)
treeb951d3eeb4522bef23f1a68a9548e1dadb67b260 /gnu/packages/golang.scm
parentead243bfb62c8a4c686402966c5ec9d0700c5f7e (diff)
downloadguix-patches-19f3b7c7b8ccd157999d004f0054c9e6217db5c0.tar
guix-patches-19f3b7c7b8ccd157999d004f0054c9e6217db5c0.tar.gz
gnu: Add go-github-com-opentracing-opentracing-go.
* gnu/packages/golang.scm (go-github-com-opentracing-opentracing-go): New variable.
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index daf64fd63e..a33178b99d 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -74,6 +74,31 @@
#:use-module (ice-9 match)
#:use-module (srfi srfi-1))
+(define-public go-github-com-opentracing-opentracing-go
+ (package
+ (name "go-github-com-opentracing-opentracing-go")
+ (version "1.2.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url "https://github.com/opentracing/opentracing-go")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "04rgdwl29kimp2wnm4dycnzp7941hvpj6wym85x23c6fclacm94h"))))
+ (build-system go-build-system)
+ (arguments
+ `(#:import-path "github.com/opentracing/opentracing-go"))
+ (native-inputs
+ `(("go-github-com-stretchr-testify"
+ ,go-github-com-stretchr-testify)))
+ (home-page "https://github.com/opentracing/opentracing-go")
+ (synopsis "OpenTracing API for Go")
+ (description "OpenTracing-Go is a Go implementation of the OpenTracing API.")
+ (license license:asl2.0)))
+
(define-public go-github-com-operatorfoundation-monolith-go
(package
(name "go-github-com-operatorfoundation-monolith-go")