summaryrefslogtreecommitdiff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorraingloom <raingloom@riseup.net>2021-11-02 06:37:11 +0000
committerRicardo Wurmus <rekado@elephly.net>2021-12-01 17:03:34 +0100
commitf3861469b6b450f6b8bd18a565789ed28b25a859 (patch)
tree7f48db794fd28566c125ffcbc501db92ec0613b1 /gnu/packages/golang.scm
parentb3a9d079b82fd46c450cd5c79c0fa00a9def386a (diff)
downloadguix-patches-f3861469b6b450f6b8bd18a565789ed28b25a859.tar
guix-patches-f3861469b6b450f6b8bd18a565789ed28b25a859.tar.gz
gnu: Add go-github-com-rivo-uniseg.
* gnu/packages/golang.scm (go-github-com-rivo-uniseg): New variable. Signed-off-by: Ricardo Wurmus <rekado@elephly.net>
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index e636a957de..236c9f1c2a 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -8861,3 +8861,25 @@ JSON for post-processing
"This package implements algorithms for exponentially weighted moving
averages.")
(license license:expat)))
+
+(define-public go-github-com-rivo-uniseg
+ (package
+ (name "go-github-com-rivo-uniseg")
+ (version "0.2.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/rivo/uniseg")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0j7h22vfmjj562vr8gpsyrkrwp1pq9ayh5fylv24skxb467g9f0q"))))
+ (build-system go-build-system)
+ (arguments '(#:import-path "github.com/rivo/uniseg"))
+ (home-page "https://github.com/rivo/uniseg")
+ (synopsis "Unicode Text Segmentation for Go")
+ (description
+ "This package implements Unicode Text Segmentation according to
+@url{https://unicode.org/reports/tr29/, Unicode Standard Annex #29}.")
+ (license license:expat)))