summaryrefslogtreecommitdiff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorRaghav Gururajan <rg@raghavgururajan.name>2021-05-24 22:16:01 -0400
committerRaghav Gururajan <rg@raghavgururajan.name>2021-07-07 09:41:22 -0400
commite6ea0abd93d2141105eaa240b777a2478598adb6 (patch)
treecc590fbe5a431b0f980f2320271d227e2cbd43d8 /gnu/packages/golang.scm
parent2fa52c8a9040b08e1c3e4f3115ca785daae1d688 (diff)
downloadguix-patches-e6ea0abd93d2141105eaa240b777a2478598adb6.tar
guix-patches-e6ea0abd93d2141105eaa240b777a2478598adb6.tar.gz
gnu: Add go-0xacab-org-leap-shapeshifter.
* gnu/packages/golang.scm (go-0xacab-org-leap-shapeshifter): New variable.
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index cf6ed4a6a5..a830afa022 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -74,6 +74,39 @@
#:use-module (ice-9 match)
#:use-module (srfi srfi-1))
+(define-public go-0xacab-org-leap-shapeshifter
+ (let ((commit "0aa6226582efb8e563540ec1d3c5cfcd19200474")
+ (revision "12"))
+ (package
+ (name "go-0xacab-org-leap-shapeshifter")
+ (version (git-version "0.0.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url "https://0xacab.org/leap/shapeshifter")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0m4fla9ppl53k9syms4dsad92wakr74cdvids3xxv3amdh4d1w4i"))))
+ (build-system go-build-system)
+ (arguments
+ `(#:import-path "0xacab.org/leap/shapeshifter"))
+ (propagated-inputs
+ `(("go-github-com-operatorfoundation-obfs4"
+ ,go-github-com-operatorfoundation-obfs4)
+ ("go-github-com-operatorfoundation-shapeshifter-transports"
+ ,go-github-com-operatorfoundation-shapeshifter-transports)
+ ("go-golang-org-x-net" ,go-golang-org-x-net)))
+ (home-page "https://0xacab.org/leap/shapeshifter")
+ (synopsis "Shapeshifter Dispatcher Library")
+ (description "Shapeshifter provides network protocol shapeshifting
+technology. The purpose of this technology is to change the characteristics of
+network traffic so that it is not identified and subsequently blocked by network
+filtering devices.")
+ (license license:bsd-2))))
+
(define-public go-github-com-operatorfoundation-shapeshifter-transports
(package
(name "go-github-com-operatorfoundation-shapeshifter-transports")