summaryrefslogtreecommitdiff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorCollin J. Doering <collin@rekahsoft.ca>2021-11-19 18:05:30 -0500
committerLudovic Courtès <ludo@gnu.org>2022-01-01 15:11:50 +0100
commitde69f20f628a8e9b57ef0f0e98d7687154eb12ba (patch)
tree0791e1078b354195ba4327068c0b7b6c0494676c /gnu/packages/golang.scm
parent60e48f1333752202322d3e8f69a6afa8bf585654 (diff)
downloadguix-patches-de69f20f628a8e9b57ef0f0e98d7687154eb12ba.tar
guix-patches-de69f20f628a8e9b57ef0f0e98d7687154eb12ba.tar.gz
gnu: Add go-open-golang
* gnu/packages/golang.scm (go-open-golang): New variable. Co-authored-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index b7b96d91ad..0e86d4a463 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -9042,3 +9042,32 @@ pcredential store, Pass, Secret Service, KDE Wallet, Encrypted File.")
(home-page "https://gopkg.in/ini.v1")
(license license:asl2.0)))
+(define-public go-github-com-skratchdot-open-golang
+ (let ((commit "79abb63cd66e41cb1473e26d11ebdcd68b04c8e5")
+ (revision "0"))
+ (package
+ (name "go-github-com-skratchdot-open-golang")
+ (version "1.42.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/skratchdot/open-golang")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0jc13jn8cj7p14n79zhav2nwga6kf9rqs01ic5k7j7agwzzly3ww"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/skratchdot/open-golang"
+ #:phases (modify-phases %standard-phases
+ (delete 'build)
+ (delete 'check))))
+ (synopsis "Open a file, directory, or URI using the default application")
+ (description
+ "Open a file, directory, or URI using the OS's default application for
+that object type. Optionally, you can specify an application to use. On
+GNU/Linux, this is a proxy for the @command{xdg-open} command.")
+ (home-page "https://github.com/skratchdot/open-golang")
+ (license license:expat))))
+