summaryrefslogtreecommitdiff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorOleg Pykhalov <go.wigust@gmail.com>2020-08-08 23:49:43 +0300
committerOleg Pykhalov <go.wigust@gmail.com>2020-08-09 17:19:19 +0300
commitf12cca097b3debac95545ef4cfc7626927267cc1 (patch)
tree782f3e49f5de65ec3f5f10a07a209a1908b15fa8 /gnu/packages/golang.scm
parent24f0001648410b5c748575c42abf8e0ae842c77a (diff)
downloadguix-patches-f12cca097b3debac95545ef4cfc7626927267cc1.tar
guix-patches-f12cca097b3debac95545ef4cfc7626927267cc1.tar.gz
gnu: Add go-github-com-alecthomas-chroma.
* gnu/packages/golang.scm (go-github-com-alecthomas-chroma): New variable.
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 129a507e3a..7847795710 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -4634,3 +4634,32 @@ synchronizing plain text:
@item aborts tests on first assertion failure
@end itemize\n")
(license license:expat))))
+
+(define-public go-github-com-alecthomas-chroma
+ (package
+ (name "go-github-com-alecthomas-chroma")
+ (version "0.8.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/alecthomas/chroma")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "066a6rdmf670d3v5sc7chbn7db09ldgxjympb03pcqwk644dixb1"))))
+ (build-system go-build-system)
+ (arguments
+ `(#:import-path "github.com/alecthomas/chroma"))
+ (native-inputs
+ `(("go-github-com-dlclark-regexp2" ,go-github-com-dlclark-regexp2)
+ ("go-github-com-alecthomas-assert" ,go-github-com-alecthomas-assert)
+ ("go-github-com-alecthomas-colour" ,go-github-com-alecthomas-colour)
+ ("go-github-com-alecthomas-repr" ,go-github-com-alecthomas-repr)
+ ("go-github-com-mattn-go-isatty" ,go-github-com-mattn-go-isatty)
+ ("go-github-com-sergi-go-diff" ,go-github-com-sergi-go-diff)))
+ (home-page "https://github.com/alecthomas/chroma/")
+ (synopsis "General purpose syntax highlighter in pure Go")
+ (description "Chroma takes source code and other structured text and
+converts it into syntax highlighted HTML, ANSI-coloured text, etc.")
+ (license license:expat)))