summaryrefslogtreecommitdiff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorOleg Pykhalov <go.wigust@gmail.com>2020-08-08 23:48:01 +0300
committerOleg Pykhalov <go.wigust@gmail.com>2020-08-09 17:19:19 +0300
commit24f0001648410b5c748575c42abf8e0ae842c77a (patch)
treef3556c93b13fa1a47ae22ec4d787181a250f6750 /gnu/packages/golang.scm
parent1871d26444e83fedfdedba943fdcfcf4745a4d04 (diff)
downloadguix-patches-24f0001648410b5c748575c42abf8e0ae842c77a.tar
guix-patches-24f0001648410b5c748575c42abf8e0ae842c77a.tar.gz
gnu: Add go-github-com-alecthomas-assert.
* gnu/packages/golang.scm (go-github-com-alecthomas-assert): New variable.
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 8f75d9ff44..129a507e3a 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -4601,3 +4601,36 @@ synchronizing plain text:
@item apply patches onto text
@end itemize\n")
(license license:expat)))
+
+(define-public go-github-com-alecthomas-assert
+ (let ((commit "405dbfeb8e38effee6e723317226e93fff912d06")
+ (revision "1"))
+ (package
+ (name "go-github-com-alecthomas-assert")
+ (version (git-version "0.0.1" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/alecthomas/assert")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1l567pi17k593nrd1qlbmiq8z9jy3qs60px2a16fdpzjsizwqx8l"))))
+ (build-system go-build-system)
+ (arguments
+ `(#:import-path "github.com/alecthomas/assert"))
+ (native-inputs
+ `(("go-github-com-mattn-go-isatty" ,go-github-com-mattn-go-isatty)
+ ("go-github-com-alecthomas-colour" ,go-github-com-alecthomas-colour)
+ ("go-github-com-alecthomas-repr" ,go-github-com-alecthomas-repr)
+ ("go-github-com-sergi-go-diff" ,go-github-com-sergi-go-diff)))
+ (home-page "https://github.com/alecthomas/assert/")
+ (synopsis "Go assertion library")
+ (description "Assertion library that:
+@itemize
+@item makes spotting differences in equality much easier
+@item uses repr and diffmatchpatch to display structural differences in colour
+@item aborts tests on first assertion failure
+@end itemize\n")
+ (license license:expat))))