summaryrefslogtreecommitdiff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorPierre Neidhardt <ambrevar@gmail.com>2018-06-22 17:42:02 +0200
committerPierre Neidhardt <ambrevar@gmail.com>2018-07-22 21:27:30 +0200
commite25ddef5bd15d532c52a4f868c22c6cea601b16c (patch)
treeb7d4c1fe8ab5d7bae5877d93b5cca6c8cc6c7684 /gnu/packages/golang.scm
parent32cb1af632b4b3b801a3493a05af4a65f9303207 (diff)
downloadguix-patches-e25ddef5bd15d532c52a4f868c22c6cea601b16c.tar
guix-patches-e25ddef5bd15d532c52a4f868c22c6cea601b16c.tar.gz
gnu: Add go-github-com-aarzilli-golua.
* gnu/packages/golang.scm (go-github-com-aarzilli-golua): New variable.
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm45
1 files changed, 45 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 26fdc9d2b8..9bcf1c7bdd 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -42,6 +42,7 @@
#:use-module (gnu packages perl)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages pcre)
+ #:use-module (gnu packages lua)
#:use-module (ice-9 match)
#:use-module (srfi srfi-1))
@@ -2061,3 +2062,47 @@ makes it possible to handle ANSI color escapes on Windows.")
(description "This package provides @code{ansi}, a Go module that can
generate ANSI colored strings.")
(license license:expat))))
+
+(define-public go-github-com-aarzilli-golua
+ (let ((commit "03fc4642d792b1f2bc5e7343b403cf490f8c501d")
+ (revision "0"))
+ (package
+ (name "go-github-com-aarzilli-golua")
+ (version (git-version "0.0.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url
+ "https://github.com/aarzilli/golua")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1d9hr29i36cza98afj3g6rs3l7xbkprwzz0blcxsr9dd7nak20di"))))
+ (build-system go-build-system)
+ (native-inputs
+ `(("lua" ,lua)))
+ (arguments
+ `(#:unpack-path "github.com/aarzilli/golua"
+ #:import-path "github.com/aarzilli/golua/lua"
+ #:phases
+ (modify-phases %standard-phases
+ (replace 'build
+ (lambda* (#:key import-path #:allow-other-keys)
+ (invoke "go" "install"
+ "-v" ; print the name of packages as they are compiled
+ "-x" ; print each command as it is invoked
+ "-ldflags=-s -w" ; strip the symbol table and debug
+ "-tags" "llua" ; Latest Lua on Guix does not have a version number.
+ import-path)))
+ (replace 'check
+ (lambda* (#:key import-path #:allow-other-keys)
+ (invoke "go" "test"
+ "-tags" "llua" ; Latest Lua on Guix does not have a version number.
+ import-path))))))
+ (home-page "https://github.com/aarzilli/golua")
+ (synopsis "Go Bindings for the Lua C API")
+ (description "This package provides @code{lua}, a Go module that can
+run a Lua virtual machine.")
+ (license license:expat))))