summaryrefslogtreecommitdiff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorPhilip McGrath <philip@philipmcgrath.com>2021-09-06 01:37:52 -0400
committerLudovic Courtès <ludo@gnu.org>2021-09-14 11:50:59 +0200
commit912880c15ec7226d82773991ac833cec4e1985b2 (patch)
treeb4af7ca70630514522d5dcc5eb913f01ff5aa221 /gnu/packages/golang.scm
parent0b7a79ff7e5922fecf8e16c4254038bf7ce64f06 (diff)
downloadguix-patches-912880c15ec7226d82773991ac833cec4e1985b2.tar
guix-patches-912880c15ec7226d82773991ac833cec4e1985b2.tar.gz
gnu: Add go-github-com-google-gmail-oauth2-tools-go-sendgmail.
* gnu/packages/golang.scm (go-github-com-google-gmail-oauth2-tools-go-sendgmail): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm35
1 files changed, 35 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 04603435a0..f02d0aa9df 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -2971,6 +2971,41 @@ with the HTTP protocol definition.")
API service accounts for Go.")
(license license:asl2.0)))
+(define-public go-github-com-google-gmail-oauth2-tools-go-sendgmail
+ (let ((commit "e3229155a4037267ce40f1a3a681f53221aa4d8d")
+ (revision "0"))
+ (package
+ (name "go-github-com-google-gmail-oauth2-tools-go-sendgmail")
+ (version (git-version "0.0.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/google/gmail-oauth2-tools")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1cxpkiaajhq1gjsg47r2b5xgck0r63pvkyrkm7af8c8dw7fyn64f"))))
+ (propagated-inputs
+ `(("go-golang-org-x-oauth2" ,go-golang-org-x-oauth2)
+ ("go-cloud-google-com-go-compute-metadata"
+ ,go-cloud-google-com-go-compute-metadata)))
+ (build-system go-build-system)
+ (arguments
+ '(#:unpack-path "github.com/google/gmail-oauth2-tools"
+ #:import-path "github.com/google/gmail-oauth2-tools/go/sendgmail"))
+ (home-page
+ "https://github.com/google/gmail-oauth2-tools/tree/master/go/sendgmail")
+ (synopsis
+ "Sendmail-compatible tool for using Gmail with @code{git send-email}")
+ (description
+ "The @command{sendgmail} command provides a minimal sendmail-compatible
+front-end that connects to Gmail using OAuth2. It is specifically designed
+for use with @code{git send-email}. The command needs a Gmail API key to
+function.")
+ (license license:asl2.0))))
+
(define-public go-github-com-google-cadvisor
(let ((commit "2ed7198f77395ee9a172878a0a7ab92ab59a2cfd")
(revision "0"))