summaryrefslogtreecommitdiff
path: root/gnu/packages/golang-xyz.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-06-23 20:25:48 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-06-23 20:25:48 +0100
commita067c4ca0a9782f6001bcbbcca0a3b3f25ce8fae (patch)
treeadb9fadb9e4b827f1b727de579ef908f85c9dacf /gnu/packages/golang-xyz.scm
parentbd7bf242f53497e7541d5e0ec59b661efb7ac60b (diff)
downloadguix-patches-a067c4ca0a9782f6001bcbbcca0a3b3f25ce8fae.tar
guix-patches-a067c4ca0a9782f6001bcbbcca0a3b3f25ce8fae.tar.gz
gnu: go-github-com-ianlancetaylor-demangle: Sort alphabetically.
* gnu/packages/golang-xyz.scm (go-github-com-ianlancetaylor-demangle): Sort variable alphabetically. Change-Id: I932fe281e3b85031a9d6207417ec26623fc26c2e
Diffstat (limited to 'gnu/packages/golang-xyz.scm')
-rw-r--r--gnu/packages/golang-xyz.scm56
1 files changed, 28 insertions, 28 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index ddeb36379e..eac495fe05 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -1762,6 +1762,34 @@ expressing configuration which is easy for both humans and machines to read.")
@end itemize")
(license license:bsd-3)))
+(define-public go-github-com-ianlancetaylor-demangle
+ ;; No release, see <https://github.com/ianlancetaylor/demangle/issues/21>.
+ (package
+ (name "go-github-com-ianlancetaylor-demangle")
+ (version "0.0.0-20230524184225-eabc099b10ab")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/ianlancetaylor/demangle")
+ (commit (go-version->git-ref version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1pvlg1adp50hnw8dz7il473xb197ixirg26cy5hj3ngb4qlajwvc"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/ianlancetaylor/demangle"))
+ (home-page "https://github.com/ianlancetaylor/demangle")
+ (synopsis "Symbol name demangler written in Go")
+ (description
+ "This package defines functions that demangle GCC/LLVM C++ and Rust
+symbol names. This package recognizes names that were mangled according to
+the C++ ABI defined at https://codesourcery.com/cxx-abi/ and the
+@url{https://rust-lang.github.io/rfcs/2603-rust-symbol-name-mangling-v0.html,Rust
+ABI}.")
+ (license license:bsd-3)))
+
(define-public go-github-com-jbenet-go-random
(package
(name "go-github-com-jbenet-go-random")
@@ -1914,34 +1942,6 @@ storing only one copy of each unique string in memory. All functions may be
called concurrently with themselves and each other.")
(license license:expat)))
-(define-public go-github-com-ianlancetaylor-demangle
- ;; No release, see <https://github.com/ianlancetaylor/demangle/issues/21>.
- (package
- (name "go-github-com-ianlancetaylor-demangle")
- (version "0.0.0-20230524184225-eabc099b10ab")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/ianlancetaylor/demangle")
- (commit (go-version->git-ref version))))
- (file-name (git-file-name name version))
- (sha256
- (base32 "1pvlg1adp50hnw8dz7il473xb197ixirg26cy5hj3ngb4qlajwvc"))))
- (build-system go-build-system)
- (arguments
- (list
- #:import-path "github.com/ianlancetaylor/demangle"))
- (home-page "https://github.com/ianlancetaylor/demangle")
- (synopsis "Symbol name demangler written in Go")
- (description
- "This package defines functions that demangle GCC/LLVM C++ and Rust
-symbol names. This package recognizes names that were mangled according to
-the C++ ABI defined at https://codesourcery.com/cxx-abi/ and the
-@url{https://rust-lang.github.io/rfcs/2603-rust-symbol-name-mangling-v0.html,Rust
-ABI}.")
- (license license:bsd-3)))
-
(define-public go-github-com-k0kubun-go-ansi
(package
(name "go-github-com-k0kubun-go-ansi")