summaryrefslogtreecommitdiff
path: root/gnu/packages/golang-xyz.scm
diff options
context:
space:
mode:
authorArtyom V. Poptsov <poptsov.artyom@gmail.com>2024-06-18 22:43:42 +0300
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-06-19 14:25:55 +0100
commit68347f87449186aa2880ce07d2d68cf67fa8cd43 (patch)
treef071d414ca663b5d1507d884204368a4fa94d65d /gnu/packages/golang-xyz.scm
parentf0df4829aa6db854a4a9d3ee1ca5affda821c2d6 (diff)
downloadguix-patches-68347f87449186aa2880ce07d2d68cf67fa8cd43.tar
guix-patches-68347f87449186aa2880ce07d2d68cf67fa8cd43.tar.gz
gnu: Add go-github-com-polydawn-refmt.
* gnu/packages/golang-xyz.scm (go-github-com-polydawn-refmt): New variable. Change-Id: I5b300fb826ec7f232cab108614737e49e114afa5 Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com>
Diffstat (limited to 'gnu/packages/golang-xyz.scm')
-rw-r--r--gnu/packages/golang-xyz.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index dec93a8f9c..591fc5b38f 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -3135,6 +3135,34 @@ on top of the standard library @code{flag} package.")
Pion}.")
(license license:expat)))
+(define-public go-github-com-polydawn-refmt
+ (package
+ (name "go-github-com-polydawn-refmt")
+ (version "0.89.1-0.20231129105047-37766d95467a")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/polydawn/refmt/")
+ (commit (go-version->git-ref version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0grgzacc7igfndk1v3n1g6k4wdz6bjsiqfq3n5br2zpr7n40ha9n"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/polydawn/refmt"))
+ (propagated-inputs
+ (list go-github-com-urfave-cli
+ go-github-com-warpfork-go-wish
+ go-github.com-smartystreets-goconvey
+ go-gopkg-in-yaml-v2))
+ (home-page "https://github.com/polydawn/refmt/")
+ (synopsis "Object mapping for Go language")
+ (description
+ "@code{refmt} is a serialization and object-mapping library.")
+ (license license:expat)))
+
(define-public go-github-com-prometheus-client-model
(package
(name "go-github-com-prometheus-client-model")