summaryrefslogtreecommitdiff
path: root/gnu/packages/golang-xyz.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-06-11 10:12:02 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-06-11 10:17:03 +0100
commit17837a9749296526021443816d3ac479de137a2d (patch)
treea5e287f82376e232ca36120f307aa12a6d34db8c /gnu/packages/golang-xyz.scm
parentbb79b85b1e024ee7d777bc9ca7b0ce4f07b8cf43 (diff)
downloadguix-patches-17837a9749296526021443816d3ac479de137a2d.tar
guix-patches-17837a9749296526021443816d3ac479de137a2d.tar.gz
gnu: Add go-github-com-tidwall-sjson.
* gnu/packages/golang-xyz.scm (go-github-com-tidwall-sjson): New variable. Change-Id: I69d5c7205a440cbf2d6abcc814b6130a6a9d4e9c
Diffstat (limited to 'gnu/packages/golang-xyz.scm')
-rw-r--r--gnu/packages/golang-xyz.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index e353b4af08..fd6ac34bb6 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -3537,6 +3537,33 @@ iteration, and parsing JSON lines.")
readability, or to compact JSON for smaller payloads.")
(license license:expat)))
+(define-public go-github-com-tidwall-sjson
+ (package
+ (name "go-github-com-tidwall-sjson")
+ (version "1.2.5")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/tidwall/sjson")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "16yaikpxiwqz00zxa70w17k2k52nr06svand88sv2br6b6i8v09r"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/tidwall/sjson"))
+ (propagated-inputs
+ (list go-github-com-tidwall-gjson
+ go-github-com-tidwall-pretty))
+ (home-page "https://github.com/tidwall/sjson")
+ (synopsis "Quick value JSON values setting in Golang")
+ (description
+ "This package provides a fast and simple way to set a value in a JSON
+document.")
+ (license license:expat)))
+
(define-public go-github-com-tklauser-go-sysconf
(package
(name "go-github-com-tklauser-go-sysconf")