summaryrefslogtreecommitdiff
path: root/gnu/packages/golang-web.scm
diff options
context:
space:
mode:
authorAdam Faiz <adam.faiz@disroot.org>2022-11-18 19:53:16 +0800
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-06-23 21:01:38 +0100
commitf9e9c6fac0d27e711c136649458a1190b2598290 (patch)
treedb4bd996acdf576837bf89e11fa24dfece190a2e /gnu/packages/golang-web.scm
parent8ca2756e56fb625a5d90d73f0bcb87349ce54e80 (diff)
downloadguix-patches-f9e9c6fac0d27e711c136649458a1190b2598290.tar
guix-patches-f9e9c6fac0d27e711c136649458a1190b2598290.tar.gz
gnu: Add go-github-com-makeworld-the-better-one-gemget.
* gnu/packages/golang-web.scm (go-github-com-makeworld-the-better-one-go-gemini): New variable. Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com> Change-Id: I904e72a2335ea95b5b7f192453da5367bbdf645e
Diffstat (limited to 'gnu/packages/golang-web.scm')
-rw-r--r--gnu/packages/golang-web.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/golang-web.scm b/gnu/packages/golang-web.scm
index e4db17b4dc..33b0cd3627 100644
--- a/gnu/packages/golang-web.scm
+++ b/gnu/packages/golang-web.scm
@@ -1363,6 +1363,34 @@ jsoniter and variable type declarations (if any). jsoniter interfaces gives
router.")
(license license:bsd-3)))
+(define-public go-github-com-makeworld-the-better-one-go-gemini
+ (package
+ (name "go-github-com-makeworld-the-better-one-go-gemini")
+ (version "0.13.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/makew0rld/go-gemini")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "196rxfg7w8s3zn87gra1mxh1l8iav6kdmg909gkbnc9cxip65zc0"))))
+ (build-system go-build-system)
+ (propagated-inputs
+ (list go-github-com-google-go-cmp-cmp
+ go-golang-org-x-net
+ go-golang-org-x-text))
+ (arguments
+ (list
+ #:import-path "github.com/makeworld-the-better-one/go-gemini"))
+ (home-page "https://github.com/makew0rld/go-gemini")
+ (synopsis "Client/server library for the Gemini protocol, in Go")
+ (description
+ "@code{go-gemini} is a library that provides an easy interface to create
+clients that speak the Gemini protocol.")
+ (license license:isc)))
+
(define-public go-github-com-microcosm-cc-bluemonday
(package
(name "go-github-com-microcosm-cc-bluemonday")