summaryrefslogtreecommitdiff
path: root/gnu/packages/golang-web.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-06-19 14:08:20 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-06-19 14:25:55 +0100
commit22e7762e39fa6afcbbfd019bf767a6091ce1a60b (patch)
tree9559d0541b67a322dd2548ad72e7f35ef352c8c9 /gnu/packages/golang-web.scm
parent2ed288dbcd8783249f07bbca28b8326017485b34 (diff)
downloadguix-patches-22e7762e39fa6afcbbfd019bf767a6091ce1a60b.tar
guix-patches-22e7762e39fa6afcbbfd019bf767a6091ce1a60b.tar.gz
gnu: Add go-github-com-quic-go-webtransport-go.
* gnu/packages/golang-web.scm (go-github-com-quic-go-webtransport-go): New variable. Change-Id: Idc9301a022b84734c737688e2dbc87e1c72d340a
Diffstat (limited to 'gnu/packages/golang-web.scm')
-rw-r--r--gnu/packages/golang-web.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/golang-web.scm b/gnu/packages/golang-web.scm
index 89761bab08..e4db17b4dc 100644
--- a/gnu/packages/golang-web.scm
+++ b/gnu/packages/golang-web.scm
@@ -2300,6 +2300,39 @@ the Go standard library}.")
protocol.")
(license license:expat)))
+(define-public go-github-com-quic-go-webtransport-go
+ (package
+ (name "go-github-com-quic-go-webtransport-go")
+ (version "0.8.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/quic-go/webtransport-go")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0zwr4jg4dg2b14kkypkbs8dpai5b5s44gm5gq0vrs3mmg6vq0v97"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:go go-1.21
+ #:import-path "github.com/quic-go/webtransport-go"))
+ (native-inputs
+ (list go-go-uber-org-mock
+ go-github-com-stretchr-testify-next))
+ (propagated-inputs
+ (list go-github-com-quic-go-quic-go
+ go-golang-org-x-exp))
+ (home-page "https://github.com/quic-go/webtransport-go")
+ (synopsis "WebTransport implementation based on quic-go")
+ (description
+ "webtransport-go is an implementation of the @code{WebTransport} protocol, based
+on @@url{https://github.com/quic-go/quic-go,quic-go}. It currently implements
+@@url{https://www.ietf.org/archive/id/draft-ietf-webtrans-http3-02.html,draft-02}
+of the specification.")
+ (license license:expat)))
+
(define-public go-github-com-sherclockholmes-webpush-go
(package
(name "go-github-com-sherclockholmes-webpush-go")