summaryrefslogtreecommitdiff
path: root/gnu/packages/golang-web.scm
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2024-04-09 16:44:22 +0100
committerChristopher Baines <mail@cbaines.net>2024-04-09 16:46:34 +0100
commit6cae1db889f62051580d5a365f62585412a53a8c (patch)
tree4d3db074d50ca3e2109cced17bec77f207a0c1fd /gnu/packages/golang-web.scm
parent410e699e0933653e69d03a4cdadf11854c6723f4 (diff)
parent35e1d9247e39f3c91512cf3d9ef1467962389e35 (diff)
downloadguix-patches-6cae1db889f62051580d5a365f62585412a53a8c.tar
guix-patches-6cae1db889f62051580d5a365f62585412a53a8c.tar.gz
Merge remote-tracking branch 'savannah/master' into mesa-updates
Change-Id: Iad185e2ced97067b3dff8fd722435a6c5e2c00e5
Diffstat (limited to 'gnu/packages/golang-web.scm')
-rw-r--r--gnu/packages/golang-web.scm56
1 files changed, 39 insertions, 17 deletions
diff --git a/gnu/packages/golang-web.scm b/gnu/packages/golang-web.scm
index e19ca4f5ff..5c6d9126ef 100644
--- a/gnu/packages/golang-web.scm
+++ b/gnu/packages/golang-web.scm
@@ -19,6 +19,7 @@
;;; Copyright © 2022 jgart via Guix-patches via <guix-patches@gnu.org>
;;; Copyright © 2022 muradm <mail@muradm.net>
;;; Copyright © 2022, 2023 Sharlatan Hellseher <sharlatanus@gmail.com>
+;;; Copyright © 2023 Fries <fries1234@protonmail.com>
;;; Copyright © 2023 Hilton Chain <hako@ultrarare.space>
;;; Copyright © 2023 Katherine Cox-Buday <cox.katherine.e@gmail.com>
;;; Copyright © 2023 Nicolas Graves <ngraves@ngraves.fr>
@@ -1188,6 +1189,40 @@ Microsoft AD PAC authorization data.")
transforms one JSON document into another through a JMESPath expression.")
(license license:asl2.0)))
+(define-public go-github-com-json-iterator-go
+ (package
+ (name "go-github-com-json-iterator-go")
+ (version "1.1.12")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/json-iterator/go")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1c8f0hxm18wivx31bs615x3vxs2j3ba0v6vxchsjhldc8kl311bz"))))
+ (build-system go-build-system)
+ (arguments
+ (list #:import-path "github.com/json-iterator/go"))
+ (native-inputs
+ (list go-github-com-davecgh-go-spew
+ go-github-com-google-gofuzz
+ go-github-com-stretchr-testify))
+ (propagated-inputs
+ (list go-github-com-modern-go-concurrent
+ go-github-com-modern-go-reflect2))
+ (home-page "https://github.com/json-iterator/go")
+ (synopsis "High-performance replacement for Golang @code{encoding/json}")
+ (description
+ "This package implements encoding and decoding of JSON as defined in
+@uref{https://rfc-editor.org/rfc/rfc4627.html,RFC 4627} and provides
+interfaces with identical syntax of standard lib encoding/json. Converting
+from encoding/json to jsoniter is no more than replacing the package with
+jsoniter and variable type declarations (if any). jsoniter interfaces gives
+100% compatibility with code using standard lib.")
+ (license license:expat)))
+
(define-public go-github-com-julienschmidt-httprouter
(package
(name "go-github-com-julienschmidt-httprouter")
@@ -1257,14 +1292,8 @@ router.")
(arguments
(list
#:import-path "github.com/multiformats/go-multiaddr"))
- (native-inputs
- (list go-github-com-gxed-hashland-keccakpg
- go-github-com-minio-blake2b-simd
- go-github-com-minio-sha256-simd
- go-github-com-mr-tron-base58
- go-github-com-multiformats-go-multihash
- go-github-com-spaolacci-murmur3
- go-golang-org-x-crypto))
+ (propagated-inputs
+ (list go-github-com-multiformats-go-multihash))
(home-page "https://github.com/multiformats/go-multiaddr")
(synopsis "Composable and future-proof network addresses")
(description
@@ -1305,15 +1334,8 @@ following:
;; TODO: Tests fail because they try to access the network.
#:tests? #f
#:import-path "github.com/multiformats/go-multiaddr-net"))
- (native-inputs
- (list go-github-com-gxed-hashland-keccakpg
- go-github-com-minio-blake2b-simd
- go-github-com-minio-sha256-simd
- go-github-com-mr-tron-base58
- go-github-com-multiformats-go-multiaddr
- go-github-com-multiformats-go-multihash
- go-github-com-spaolacci-murmur3
- go-golang-org-x-crypto))
+ (propagated-inputs
+ (list go-github-com-multiformats-go-multiaddr))
(home-page "https://github.com/multiformats/go-multiaddr-net")
(synopsis "Multiaddress net tools")
(description