summaryrefslogtreecommitdiff
path: root/gnu/packages/golang-crypto.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-01-16 23:53:40 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-01-28 23:21:05 +0000
commit857be8fb4713a399120e3357ccb02a89989a7675 (patch)
tree7fc85140acd624d8db1db65589e4f03c4f6108de /gnu/packages/golang-crypto.scm
parentfb63bfb9d5d1983aaa67d2ba6447ba7cb71769a6 (diff)
downloadguix-patches-857be8fb4713a399120e3357ccb02a89989a7675.tar
guix-patches-857be8fb4713a399120e3357ccb02a89989a7675.tar.gz
gnu: go-lukechampine-com-blake3: Move to (gnu packages golang-crypto).
* gnu/packages/golang.scm (go-lukechampine-com-blake3): Move from here ... * gnu/packages/golang-crypto.scm: ... to here. * gnu/packages/uucp.scm: Add (gnu packages golang-crypto) to used modules. Change-Id: I56dba8380317a0f58f92140889611ac3075af2cf
Diffstat (limited to 'gnu/packages/golang-crypto.scm')
-rw-r--r--gnu/packages/golang-crypto.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/golang-crypto.scm b/gnu/packages/golang-crypto.scm
index 91def02194..bfeea103ca 100644
--- a/gnu/packages/golang-crypto.scm
+++ b/gnu/packages/golang-crypto.scm
@@ -2,6 +2,7 @@
;;; Copyright © 2018 Pierre Neidhardt <mail@ambrevar.xyz>
;;; Copyright © 2019 Vagrant Cascadian <vagrant@debian.org>
;;; Copyright © 2019, 2020 Leo Famulari <leo@famulari.name>
+;;; Copyright © 2021 Arun Isaac <arunisaac@systemreboot.net>
;;; Copyright © 2021 Raghav Gururajan <rg@raghavgururajan.name>
;;; Copyright © 2022 (unmatched-parenthesis <paren@disroot.org>
;;; Copyright © 2022, 2023 Nicolas Graves <ngraves@ngraves.fr>
@@ -612,6 +613,31 @@ package is intended for interoperability with the standard library and the
possible.")
(license license:bsd-3))))
+(define-public go-lukechampine-com-blake3
+ (package
+ (name "go-lukechampine-com-blake3")
+ (version "1.1.5")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/lukechampine/blake3")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1yxdwp8dpnnq2wbwsxlkbq570i99sc6781y39czjxi9jh9z5nw55"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "lukechampine.com/blake3"))
+ (propagated-inputs
+ (list go-github-com-klauspost-cpuid))
+ (home-page "https://pkg.go.dev/lukechampine.com/blake3")
+ (synopsis "Implementation of the BLAKE3 cryptographic hash function")
+ (description "@code{blake3} implements the BLAKE3 cryptographic hash
+function. In addition to the pure-Go implementation, this package also
+contains AVX-512 and AVX2 routines (generated by avo) that greatly increase
+performance for large inputs and outputs.")
+ (license license:expat)))
;;;
;;; Avoid adding new packages to the end of this file. To reduce the chances