summaryrefslogtreecommitdiff
path: root/gnu/packages/golang-compression.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-02-10 22:27:29 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-02-13 14:33:16 +0000
commit8af7c33818b241464f5968af3c1f06e42ae7290c (patch)
treeae63a24fecd8e8b4b9c29abe510fa7407e70186c /gnu/packages/golang-compression.scm
parentd8f69addc2e6a3045e4ed9e91a6ac2b5829e6068 (diff)
downloadguix-patches-8af7c33818b241464f5968af3c1f06e42ae7290c.tar
guix-patches-8af7c33818b241464f5968af3c1f06e42ae7290c.tar.gz
gnu: go-github-com-andybalholm-brotli: Move to golang-compression.
* gnu/packages/golang.scm (go-github-com-andybalholm-brotli): Move from here ... * gnu/packages/golang-compression.scm: ... to here. Change-Id: I820b0211b1fe4d90643e82fc32a99d8e8b6a9b0f
Diffstat (limited to 'gnu/packages/golang-compression.scm')
-rw-r--r--gnu/packages/golang-compression.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/golang-compression.scm b/gnu/packages/golang-compression.scm
index 5aacc34a66..6a556daa25 100644
--- a/gnu/packages/golang-compression.scm
+++ b/gnu/packages/golang-compression.scm
@@ -2,6 +2,7 @@
;;; Copyright © 2017 Leo Famulari <leo@famulari.name>
;;; Copyright © 2021 Arun Isaac <arunisaac@systemreboot.net>
;;; Copyright © 2021 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2022 Sharlatan Hellseher <sharlatanus@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -33,6 +34,32 @@
;;;
;;; Code:
+(define-public go-github-com-andybalholm-brotli
+ (package
+ (name "go-github-com-andybalholm-brotli")
+ (version "1.0.4")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/andybalholm/brotli")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1zvmj7gbnkq9xwv1bvcxk9acxl06y902148qwbd2kqwgs52wy2c0"))))
+ (build-system go-build-system)
+ (arguments
+ `(#:import-path "github.com/andybalholm/brotli"))
+ (home-page "https://github.com/andybalholm/brotli")
+ (synopsis "Pure Go Brotli encoder and decoder")
+ (description
+ "This package is a brotli compressor and decompressor implemented in Go.
+It was translated from the reference implementation
+(@url{https://github.com/google/brotli,https://github.com/google/brotli}) with
+the @code{c2go} tool at
+@url{https://github.com/andybalholm/c2go,https://github.com/andybalholm/c2go}.")
+ (license license:expat)))
+
(define-public go-github-com-golang-snappy
(package
(name "go-github-com-golang-snappy")