summaryrefslogtreecommitdiff
path: root/gnu/packages/golang-check.scm
diff options
context:
space:
mode:
authorNicolas Graves <ngraves@ngraves.fr>2024-01-27 19:21:31 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-01-31 21:20:17 +0000
commita27d0f975b1c9ab87e2d2659f426feb5de018bce (patch)
tree698cea5fa45e3c461ebd360bbd6b33009924890c /gnu/packages/golang-check.scm
parent98651390a75609106464b80a35b0b8be745cb2a3 (diff)
downloadguix-patches-a27d0f975b1c9ab87e2d2659f426feb5de018bce.tar
guix-patches-a27d0f975b1c9ab87e2d2659f426feb5de018bce.tar.gz
gnu: Add go-structlayout-pretty.
* gnu/packages/golang-check.scm (go-structlayout-pretty): New variable. Change-Id: I622a991b12708ee52eb412a3c6b3fbeeb512843d Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com>
Diffstat (limited to 'gnu/packages/golang-check.scm')
-rw-r--r--gnu/packages/golang-check.scm12
1 files changed, 12 insertions, 0 deletions
diff --git a/gnu/packages/golang-check.scm b/gnu/packages/golang-check.scm
index 52818023a4..6acf4e42ea 100644
--- a/gnu/packages/golang-check.scm
+++ b/gnu/packages/golang-check.scm
@@ -138,6 +138,18 @@ flag.")))
reorders fields to minimize the amount of padding. It can emit JSON to feed
into @code{go-structlayout-pretty}.")))
+(define-public go-structlayout-pretty
+ (package
+ (inherit go-honnef-co-go-tools)
+ (name "go-structlayout-pretty")
+ (arguments
+ `(#:import-path "honnef.co/go/tools/cmd/structlayout-pretty"
+ #:unpack-path "honnef.co/go/tools"
+ #:install-source? #f))
+ (synopsis "Format the output of go-structlayout with ASCII art in Go")
+ (description "This package takes @code{go-structlayout}-like JSON and
+prints an ASCII fraphic representing the memory layout.")))
+
(define-public go-github-com-alecthomas-assert
(let ((commit "405dbfeb8e38effee6e723317226e93fff912d06")
(revision "1"))