summaryrefslogtreecommitdiff
path: root/gnu/packages/golang-check.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-01-17 22:13:38 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-01-28 23:21:06 +0000
commit8882af2572de94b93cce3be6ebccf0bee51f8ee1 (patch)
tree63d402f448b5492065bc45c2276415014d539e03 /gnu/packages/golang-check.scm
parent88fea61aaed0498ab81928933a3b4293a7656549 (diff)
downloadguix-patches-8882af2572de94b93cce3be6ebccf0bee51f8ee1.tar
guix-patches-8882af2572de94b93cce3be6ebccf0bee51f8ee1.tar.gz
gnu: go-github.com-smartystreets-assertions: Move to (gnu packages golang-check).
* gnu/packages/check.scm (go-github.com-smartystreets-assertions): Move from here ... * gnu/packages/golang-check.scm: ... to here. Change-Id: Ia90bbe984fe19dd48d9df91364a7ecf2bf8bd37f
Diffstat (limited to 'gnu/packages/golang-check.scm')
-rw-r--r--gnu/packages/golang-check.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/golang-check.scm b/gnu/packages/golang-check.scm
index 207e4a548f..0c37849806 100644
--- a/gnu/packages/golang-check.scm
+++ b/gnu/packages/golang-check.scm
@@ -4,6 +4,7 @@
;;; Copyright © 2018 Pierre-Antoine Rouby <pierre-antoine.rouby@inria.fr>
;;; Copyright © 2019 Brian Leung <bkleung89@gmail.com>
;;; Copyright © 2019 Leo Famulari <leo@famulari.name>
+;;; Copyright © 2019 Vagrant Cascadian <vagrant@debian.org>
;;; Copyright © 2020 Jakub Kądziołka <kuba@kadziolka.net>
;;; Copyright © 2020 Joseph LaFreniere <joseph@lafreniere.xyz>
;;; Copyright © 2020 Oleg Pykhalov <go.wigust@gmail.com>
@@ -379,6 +380,38 @@ builds on top of Go's builtin @code{testing} library and is complemented by the
Gomega matcher library.")
(license license:expat)))
+(define-public go-github.com-smartystreets-assertions
+ (package
+ (name "go-github.com-smartystreets-assertions")
+ (version "1.13.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/smartystreets/assertions")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256 (base32 "0flf3fb6fsw3bk1viva0fzrzw87djaj1mqvrx2gzg1ssn7xzfrzr"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/smartystreets/assertions"
+ #:phases
+ #~(modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key inputs #:allow-other-keys #:rest args)
+ (unless
+ ;; The tests fail when run with gccgo.
+ (false-if-exception (search-input-file inputs "/bin/gccgo"))
+ (apply (assoc-ref %standard-phases 'check) args)))))))
+ (native-inputs
+ (list go-github.com-smartystreets-gunit))
+ (home-page "https://github.com/smartystreets/assertions")
+ (synopsis "Assertions for testing with Go")
+ (description "The @code{assertions} package provides convenient assertion
+functions for writing tests in Go.")
+ (license license:expat)))
+
(define-public go-github.com-smartystreets-gunit
(package
(name "go-github.com-smartystreets-gunit")