summaryrefslogtreecommitdiff
path: root/gnu/packages/golang-check.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-02-01 07:42:07 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-02-01 07:52:02 +0000
commit82dacb49b23c089fcf3dff0303635c0f5a6d3b77 (patch)
treec6ebaaba7c809baccd8f26989afec49c85845dda /gnu/packages/golang-check.scm
parent1eeeeb8add447cee778c05363a0a772a89afcb6e (diff)
downloadguix-patches-82dacb49b23c089fcf3dff0303635c0f5a6d3b77.tar
guix-patches-82dacb49b23c089fcf3dff0303635c0f5a6d3b77.tar.gz
gnu: go-keyify: Fix build.
* gnu/packages/golang-check.scm (go-keyify) [arguments] <#:go>: Swap to go-20. Change-Id: Ida1aafbbbf4c6a0ff8104c81b82b66c7ecb64218
Diffstat (limited to 'gnu/packages/golang-check.scm')
-rw-r--r--gnu/packages/golang-check.scm3
1 files changed, 2 insertions, 1 deletions
diff --git a/gnu/packages/golang-check.scm b/gnu/packages/golang-check.scm
index fc142d87e7..af193fcd26 100644
--- a/gnu/packages/golang-check.scm
+++ b/gnu/packages/golang-check.scm
@@ -661,7 +661,8 @@ advanced Go linter.")
(inherit go-honnef-co-go-tools)
(name "go-keyify")
(arguments
- `(#:import-path "honnef.co/go/tools/cmd/keyify"
+ `(#:go ,go-1.20
+ #:import-path "honnef.co/go/tools/cmd/keyify"
#:unpack-path "honnef.co/go/tools"
#:install-source? #f))
(synopsis "Transform an unkeyed struct literal into a keyed one in Go")