summaryrefslogtreecommitdiff
path: root/gnu/packages/gnuzilla.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2017-06-12 19:27:02 +0200
committerMarius Bakke <mbakke@fastmail.com>2017-06-12 21:31:12 +0200
commita10040e09b29eef72404c1f757fa7e20eb501dbb (patch)
tree6b076539122b1bc747879d41c76fb9203903384f /gnu/packages/gnuzilla.scm
parentc4395e782ea7c1392c91c3b491742127eb3de485 (diff)
downloadguix-patches-a10040e09b29eef72404c1f757fa7e20eb501dbb.tar
guix-patches-a10040e09b29eef72404c1f757fa7e20eb501dbb.tar.gz
gnu: nss, nss-certs: Update to 3.31.
Release notes: <https://developer.mozilla.org/en-US/docs/Mozilla/Projects/NSS/NSS_3.31_release_notes> * gnu/packages/certs.scm (nss-certs): Update to 3.31. * gnu/packages/gnuzilla.scm (nss): Likewise. [source]<patches>: Remove upstream 'nss-disable-long-b64-tests' patch. [arguments]<#:phases>: Move armhf timeout substitution ... * gnu/packages/patches/nss-increase-test-timeout.patch: ... here. * gnu/packages/patches/nss-disable-long-b64-tests.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Remove it.
Diffstat (limited to 'gnu/packages/gnuzilla.scm')
-rw-r--r--gnu/packages/gnuzilla.scm15
1 files changed, 2 insertions, 13 deletions
diff --git a/gnu/packages/gnuzilla.scm b/gnu/packages/gnuzilla.scm
index 23d8d73a7e..e0f80a1868 100644
--- a/gnu/packages/gnuzilla.scm
+++ b/gnu/packages/gnuzilla.scm
@@ -282,7 +282,7 @@ in the Mozilla clients.")
(define-public nss
(package
(name "nss")
- (version "3.30.2")
+ (version "3.31")
(source (origin
(method url-fetch)
(uri (let ((version-with-underscores
@@ -293,10 +293,9 @@ in the Mozilla clients.")
"nss-" version ".tar.gz")))
(sha256
(base32
- "096frzvyp3z257x84rxknscfgsbavzh2a0gyibx7kvmw4vzpfjhd"))
+ "0pd643a8ns7q5az5ai3ascrw666i2kbfiyy1c9hlhw9jd8jn21g9"))
;; Create nss.pc and nss-config.
(patches (search-patches "nss-pkgconfig.patch"
- "nss-disable-long-b64-tests.patch"
"nss-increase-test-timeout.patch"))))
(build-system gnu-build-system)
(outputs '("out" "bin"))
@@ -329,16 +328,6 @@ in the Mozilla clients.")
`((setenv "USE_64" "1")))
(_
'()))
- ;; The timeout values in "increase-test-timeouts" are still
- ;; too low, so apply this workaround on armhf for now to avoid
- ;; rebuilding on all platforms. This should be incorporated in
- ;; the patch for the next update.
- ;; https://lists.gnu.org/archive/html/guix-devel/2017-04/msg00472.html
- ,@(if (string-prefix? "armhf" (or (%current-target-system)
- (%current-system)))
- `((substitute* "nss/gtests/ssl_gtest/tls_connect.cc"
- (("25000\\);") "300000);")))
- '())
#t))
(replace 'check
(lambda _