summaryrefslogtreecommitdiff
path: root/gnu/packages/gnuzilla.scm
diff options
context:
space:
mode:
authorJonathan Brielmaier <jonathan.brielmaier@web.de>2021-01-27 10:09:58 +0100
committerJonathan Brielmaier <jonathan.brielmaier@web.de>2021-01-27 10:09:58 +0100
commitfa3461428140532283f6133ec599d6e7afabe5f8 (patch)
treeceb02879c4b256684f9af8aa917c66adbba46195 /gnu/packages/gnuzilla.scm
parentcf5e0b2636379cfe1cce67f928a2867efb088865 (diff)
downloadguix-patches-fa3461428140532283f6133ec599d6e7afabe5f8.tar
guix-patches-fa3461428140532283f6133ec599d6e7afabe5f8.tar.gz
gnu: icedove: Update to 78.7.0 [fixes CVE-2020-15685].
* gnu/packages/gnuzilla.scm (%icedove-build-id, icedove): Update.
Diffstat (limited to 'gnu/packages/gnuzilla.scm')
-rw-r--r--gnu/packages/gnuzilla.scm8
1 files changed, 4 insertions, 4 deletions
diff --git a/gnu/packages/gnuzilla.scm b/gnu/packages/gnuzilla.scm
index b5d5013066..93e3690bb0 100644
--- a/gnu/packages/gnuzilla.scm
+++ b/gnu/packages/gnuzilla.scm
@@ -1305,11 +1305,11 @@ standards of the IceCat project.")
(cpe-version . ,(first (string-split version #\-)))))))
;; Update this together with icecat!
-(define %icedove-build-id "20210111000000") ;must be of the form YYYYMMDDhhmmss
+(define %icedove-build-id "20210126000000") ;must be of the form YYYYMMDDhhmmss
(define-public icedove
(package
(name "icedove")
- (version "78.6.1")
+ (version "78.7.0")
(source icecat-source)
(properties
`((cpe-name . "thunderbird_esr")))
@@ -1589,7 +1589,7 @@ standards of the IceCat project.")
;; in the Thunderbird release tarball. We don't use the release
;; tarball because it duplicates the Icecat sources and only adds the
;; "comm" directory, which is provided by this repository.
- ,(let ((changeset "f99e82f3f3cae6af48006c39fceb3beeabccd6f6"))
+ ,(let ((changeset "d4c4077a3ef9b3221984f2d0b42f1d96c35776e8"))
(origin
(method hg-fetch)
(uri (hg-reference
@@ -1598,7 +1598,7 @@ standards of the IceCat project.")
(file-name (string-append "thunderbird-" version "-checkout"))
(sha256
(base32
- "0mrar1qsvvlcggzz54nxi70jzk19mq42585905kb5n90ikr9q2q7")))))
+ "0yabs4zlwb5jvlyk45lbw1nzfmra1f8bbwvwcwxjs1a8wcmrmb39")))))
("autoconf" ,autoconf-2.13)
("cargo" ,rust-1.41 "cargo")
("clang" ,clang)