summaryrefslogtreecommitdiff
path: root/gnu/packages/gnuzilla.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2018-12-03 08:52:17 +0100
committerLudovic Courtès <ludo@gnu.org>2018-12-03 08:52:17 +0100
commit194451347dc60092132d06b84a83c5205d79299a (patch)
tree828475b685c349cdd7b74c09beb7336d38bdf6f0 /gnu/packages/gnuzilla.scm
parent37c6f11f8dfa1880db86a3510c9e50990304d76c (diff)
parent8cddb0d6363d13f74de5409ef29b7913228f49b9 (diff)
downloadguix-patches-194451347dc60092132d06b84a83c5205d79299a.tar
guix-patches-194451347dc60092132d06b84a83c5205d79299a.tar.gz
Merge branch 'core-updates'
Diffstat (limited to 'gnu/packages/gnuzilla.scm')
-rw-r--r--gnu/packages/gnuzilla.scm11
1 files changed, 9 insertions, 2 deletions
diff --git a/gnu/packages/gnuzilla.scm b/gnu/packages/gnuzilla.scm
index e1abe8c2cd..d6b1f4c2d6 100644
--- a/gnu/packages/gnuzilla.scm
+++ b/gnu/packages/gnuzilla.scm
@@ -39,6 +39,7 @@
#:use-module (gnu packages audio)
#:use-module (gnu packages autotools)
#:use-module (gnu packages base)
+ #:use-module (gnu packages check)
#:use-module (gnu packages databases)
#:use-module (gnu packages glib)
#:use-module (gnu packages gtk)
@@ -417,7 +418,12 @@ in the Mozilla clients.")
(setenv "DOMSUF" "(none)")
(setenv "USE_IP" "TRUE")
(setenv "IP_ADDRESS" "127.0.0.1")
- (invoke "./nss/tests/all.sh")))
+
+ ;; The "PayPalEE.cert" certificate expires every six months,
+ ;; leading to test failures:
+ ;; <https://bugzilla.mozilla.org/show_bug.cgi?id=609734>. To
+ ;; work around that, set the time to roughly the release date.
+ (invoke "faketime" "2018-09-01" "./nss/tests/all.sh")))
(replace 'install
(lambda* (#:key outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))
@@ -453,7 +459,8 @@ in the Mozilla clients.")
`(("sqlite" ,sqlite)
("zlib" ,zlib)))
(propagated-inputs `(("nspr" ,nspr))) ; required by nss.pc.
- (native-inputs `(("perl" ,perl)))
+ (native-inputs `(("perl" ,perl)
+ ("libfaketime" ,libfaketime))) ;for tests
;; The NSS test suite takes around 48 hours on Loongson 3A (MIPS) when
;; another build is happening concurrently on the same machine.