summaryrefslogtreecommitdiff
path: root/gnu/packages/gnupg.scm
diff options
context:
space:
mode:
authorJanneke Nieuwenhuizen <janneke@gnu.org>2023-06-06 20:39:50 +0200
committerJanneke Nieuwenhuizen <janneke@gnu.org>2023-07-20 10:11:33 +0200
commitebc35c609649ef2a859307171aac17c0bf927b87 (patch)
tree661776c19baf1c68aff6bc01b8ae108de6ff3ed1 /gnu/packages/gnupg.scm
parentc5991dfb921f1f5b5f3785eff611771896e965aa (diff)
downloadguix-patches-ebc35c609649ef2a859307171aac17c0bf927b87.tar
guix-patches-ebc35c609649ef2a859307171aac17c0bf927b87.tar.gz
gnu: libgcrypt: Skip hanging benchmark tests on the Hurd.
* gnu/packages/gnupg.scm (libgcrypt)[arguments]: When building natively on the Hurd, add phase 'setenv' to set "GCRYPT_NO_BENCHMARKS".
Diffstat (limited to 'gnu/packages/gnupg.scm')
-rw-r--r--gnu/packages/gnupg.scm10
1 files changed, 9 insertions, 1 deletions
diff --git a/gnu/packages/gnupg.scm b/gnu/packages/gnupg.scm
index 4a9a8fbb57..8d92c60bf2 100644
--- a/gnu/packages/gnupg.scm
+++ b/gnu/packages/gnupg.scm
@@ -204,7 +204,15 @@ Daemon and possibly more in the future.")
,@(if (%current-target-system)
;; When cross-compiling, _gcry_mpih_lshift etc are undefined.
`("--disable-asm")
- '()))))
+ '()))
+ ,@(if (system-hurd?)
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-before 'configure 'setenv
+ (lambda _
+ (setenv "GCRYPT_NO_BENCHMARKS" "t")))))
+ '())))
(outputs '("out" "debug"))
(home-page "https://gnupg.org/")
(synopsis "Cryptographic function library")