summaryrefslogtreecommitdiff
path: root/gnu/packages/gnupg.scm
diff options
context:
space:
mode:
authorLiliana Marie Prikler <liliana.prikler@gmail.com>2024-02-13 16:11:14 +0100
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2024-02-13 16:11:14 +0100
commit622df12ef389c9e91f68ae10c54c043f34828c83 (patch)
tree888542636c0717727d52a4cd56d42338601e661a /gnu/packages/gnupg.scm
parent952c691b51f8f5d56df69686c2785414709c7949 (diff)
parent8a0910e042ad1670435613e06458a6fb2c4131c4 (diff)
downloadguix-patches-622df12ef389c9e91f68ae10c54c043f34828c83.tar
guix-patches-622df12ef389c9e91f68ae10c54c043f34828c83.tar.gz
Merge branch 'master' into gnome-team
Diffstat (limited to 'gnu/packages/gnupg.scm')
-rw-r--r--gnu/packages/gnupg.scm32
1 files changed, 27 insertions, 5 deletions
diff --git a/gnu/packages/gnupg.scm b/gnu/packages/gnupg.scm
index 59232f0c77..1bf6eee2ff 100644
--- a/gnu/packages/gnupg.scm
+++ b/gnu/packages/gnupg.scm
@@ -346,11 +346,33 @@ compatible to GNU Pth.")
zlib))
(arguments
(list
- #:configure-flags #~'(;; Otherwise, the test suite looks for the `gpg`
- ;; executable in its installation directory in
- ;; /gnu/store before it has been installed.
- "--enable-gnupg-builddir-envvar"
- "--enable-all-tests")
+ #:configure-flags
+ ;; Always use quasiquote on the next core-updates cycle.
+ #~(#$(if (%current-target-system)
+ #~quasiquote
+ #~quote)
+ (#$@(if (%current-target-system)
+ #~(,(string-append
+ "--with-libgpg-error-prefix="
+ #$(this-package-input "libgpg-error"))
+ ,(string-append
+ "--with-libgcrypt-prefix="
+ #$(this-package-input "libgcrypt"))
+ ,(string-append
+ "--with-libassuan-prefix="
+ #$(this-package-input "libassuan"))
+ ,(string-append
+ "--with-ksba-prefix="
+ #$(this-package-input "libksba"))
+ ,(string-append
+ "--with-npth-prefix="
+ #$(this-package-input "npth")))
+ #~())
+ ;; Otherwise, the test suite looks for the `gpg`
+ ;; executable in its installation directory in
+ ;; /gnu/store before it has been installed.
+ "--enable-gnupg-builddir-envvar"
+ "--enable-all-tests"))
#:phases
#~(modify-phases %standard-phases
(add-before 'configure 'patch-paths