summaryrefslogtreecommitdiff
path: root/gnu/packages/gnunet.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2024-03-12 21:56:17 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2024-03-13 00:38:11 -0400
commit43d6d5e6461d930dda4846279b3d56c97467bc06 (patch)
tree42adb38d52ca28576f1766cda63bb48a888fa945 /gnu/packages/gnunet.scm
parente1e3536ecea9cba7d4be109af438a45caf8d5eae (diff)
downloadguix-patches-43d6d5e6461d930dda4846279b3d56c97467bc06.tar
guix-patches-43d6d5e6461d930dda4846279b3d56c97467bc06.tar.gz
gnu: libextractor: Enable tidy-html support.
* gnu/packages/gnunet.scm (libextractor) [source]: Apply patch. [phases] <force-reconfigure>: New phase. [inputs]: Add tidy-html. Remove associated comment. * gnu/packages/patches/libextractor-tidy-support.patch: New file. * gnu/local.mk (dist_patch_DATA): Register it. Change-Id: Ic812e09504d522ec87410bbbb03ccd3d6e48dd71
Diffstat (limited to 'gnu/packages/gnunet.scm')
-rw-r--r--gnu/packages/gnunet.scm14
1 files changed, 7 insertions, 7 deletions
diff --git a/gnu/packages/gnunet.scm b/gnu/packages/gnunet.scm
index 828ddb99af..e23755302d 100644
--- a/gnu/packages/gnunet.scm
+++ b/gnu/packages/gnunet.scm
@@ -93,7 +93,9 @@
version ".tar.gz"))
(sha256
(base32
- "0mgprmwdhdwq9xhfxfhcncd304425nvcc4zi8ci5f0nja4n333xv"))))
+ "0mgprmwdhdwq9xhfxfhcncd304425nvcc4zi8ci5f0nja4n333xv"))
+ (patches
+ (search-patches "libextractor-tidy-support.patch"))))
(build-system gnu-build-system)
(outputs '("out"
"static")) ; 420 KiB .a files
@@ -103,6 +105,9 @@
#$(this-package-input "libltdl")))
#:phases
#~(modify-phases %standard-phases
+ (add-after 'unpack 'force-reconfigure
+ (lambda _
+ (delete-file "configure")))
(add-after 'install 'move-static-libraries
(lambda* (#:key outputs #:allow-other-keys)
;; Move static libraries to the "static" output.
@@ -114,12 +119,6 @@
(install-file file slib)
(delete-file file))
(find-files lib "\\.a$"))))))))
- ;; WARNING: Checks require /dev/shm to be in the build chroot, especially
- ;; not to be a symbolic link to /run/shm.
- ;; FIXME:
- ;; The following dependency is optional, but should be
- ;; available for maximum coverage:
- ;; * libtidy-html (tidy-html) ; investigate failure
(native-inputs
(list autoconf-2.71
automake
@@ -149,6 +148,7 @@
libtiff
libvorbis
rpm
+ tidy-html
zlib))
(synopsis "Library to extract meta-data from media files")
(description