summaryrefslogtreecommitdiff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
authorMathieu Othacehe <othacehe@gnu.org>2021-08-19 11:12:57 +0200
committerMathieu Othacehe <othacehe@gnu.org>2021-08-19 16:01:27 +0200
commit92ed7df03400172ce0d7ec5df8f65580e4ac234b (patch)
treefc6f4acbcb1bab4af10f9098de094bb03cb0fb6d /gnu/packages/gnome.scm
parent004cab1bf6f211adb4afe3a0fec39bf5c7c81d35 (diff)
downloadguix-patches-92ed7df03400172ce0d7ec5df8f65580e4ac234b.tar
guix-patches-92ed7df03400172ce0d7ec5df8f65580e4ac234b.tar.gz
gnu: libhandy: Update to 1.2.3.
* gnu/packages/gnome.scm (libhandy): Update to 1.2.3. [arguments]: Disable documentation generation. Add a new patch-docbook-xml phase. [inputs]: Add glade and remove libxml2. [native-inputs]: Add libxml, libxslt, docbook-xsl and docbook-xml for the documentation generation.
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm25
1 files changed, 20 insertions, 5 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index d5ef8a331b..f20e34c8ac 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -10874,7 +10874,7 @@ tabs, and it supports drag and drop re-ordering of terminals.")
(define-public libhandy
(package
(name "libhandy")
- (version "1.2.2")
+ (version "1.2.3")
(source
(origin
(method git-fetch)
@@ -10883,14 +10883,26 @@ tabs, and it supports drag and drop re-ordering of terminals.")
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "0345x7gif6yjm95y62lww71lj84wfwsr2p32r3iww8shavb8scyk"))))
+ (base32 "1ng2607cp4dfl169rj7zi8q5p6fzxy3a4l0glm7mj75yd1a603rz"))))
(build-system meson-build-system)
(arguments
`(#:configure-flags
'("-Dglade_catalog=enabled"
- "-Dgtk_doc=true")
+ ;; XXX: Generating the documentation fails because the
+ ;; libhandy.devhelp2 document cannot be created. This seems to be
+ ;; caused by a problem during the XSL transformation.
+ "-Dgtk_doc=false")
#:phases
(modify-phases %standard-phases
+ (add-after 'unpack 'patch-docbook-xml
+ (lambda* (#:key inputs #:allow-other-keys)
+ (for-each
+ (lambda (file)
+ (substitute* file
+ (("http://www.oasis-open.org/docbook/xml/4.3/docbookx.dtd")
+ (search-input-file inputs
+ "/xml/dtd/docbook/docbookx.dtd"))))
+ (find-files "doc" "\\.xml"))))
(add-before 'check 'pre-check
(lambda _
;; Tests require a running X server.
@@ -10899,12 +10911,15 @@ tabs, and it supports drag and drop re-ordering of terminals.")
#t)))))
(inputs
`(("gtk+" ,gtk+)
- ("glade" ,glade3)
- ("libxml2" ,libxml2)))
+ ("glade" ,glade3)))
(native-inputs
`(("glib:bin" ,glib "bin")
("gobject-introspection" ,gobject-introspection) ; for g-ir-scanner
("vala" ,vala)
+ ("libxml2" ,libxml2)
+ ("libxslt" ,libxslt)
+ ("docbook-xsl" ,docbook-xsl)
+ ("docbook-xml" ,docbook-xml-4.3)
("gtk-doc" ,gtk-doc/stable)
("pkg-config" ,pkg-config)
("gettext" ,gettext-minimal)