summaryrefslogtreecommitdiff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-09-11 22:30:08 +0300
committerEfraim Flashner <efraim@flashner.co.il>2021-09-11 23:10:45 +0300
commit536c2ee167c85807b3ec79eae149e72ac1932c7a (patch)
tree3ee1e46556ea1ffc4411621ff499f02c93ba0859 /gnu/packages/gnome.scm
parent6a85d80eb9e40a55a783c7794d744a63e3ae7246 (diff)
downloadguix-patches-536c2ee167c85807b3ec79eae149e72ac1932c7a.tar
guix-patches-536c2ee167c85807b3ec79eae149e72ac1932c7a.tar.gz
gnu: librsvg: Simplify custom phase.
* gnu/packages/gnome.scm (librsvg)[arguments]: Adjust custom 'gnu-configure phase to use more default arguments.
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm20
1 files changed, 9 insertions, 11 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 5abdc990c5..3a131e7494 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -3454,17 +3454,15 @@ for dealing with different structured file formats.")
(("gdk_pixbuf_cache_file = .*$")
"gdk_pixbuf_cache_file = $(TMPDIR)/loaders.cache\n"))))
(add-after 'configure 'gnu-configure
- (lambda* (#:key inputs native-inputs outputs #:allow-other-keys)
- ((assoc-ref gnu:%standard-phases 'configure)
- #:native-inputs native-inputs
- #:inputs inputs
- #:outputs outputs
- #:configure-flags
- (list "--disable-static"
- "--enable-vala"
- (string-append "--with-html-dir="
- (assoc-ref outputs "doc")
- "/share/gtk-doc/html")))))
+ (lambda* (#:key outputs #:allow-other-keys #:rest args)
+ (apply (assoc-ref gnu:%standard-phases 'configure)
+ #:configure-flags
+ (list "--disable-static"
+ "--enable-vala"
+ (string-append "--with-html-dir="
+ (assoc-ref outputs "doc")
+ "/share/gtk-doc/html"))
+ args)))
(add-after 'configure 'dont-vendor-self
(lambda* (#:key vendor-dir #:allow-other-keys)
;; Don't keep the whole tarball in the vendor directory