summaryrefslogtreecommitdiff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2021-06-28 12:09:23 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2021-06-28 18:04:15 +0200
commit35188a82570348c1c47dadf94bd273942a75c20a (patch)
tree5b63fdcaaf3a74c15481231d90b0f8ddeb0ac911 /gnu/packages/gnome.scm
parent23bc34e443abfc974b3d5ab45717072a7b6cbe1b (diff)
downloadguix-patches-35188a82570348c1c47dadf94bd273942a75c20a.tar
guix-patches-35188a82570348c1c47dadf94bd273942a75c20a.tar.gz
gnu: upower: Build from Git sources.
* gnu/packages/gnome.scm (upower)[source]: Use GIT-FETCH and GIT-FILE-NAME. Adjust snippet. [native-inputs]: Add autoconf, automake, gtk-doc, libtool, and which. * gnu/packages/patches/upower-builddir.patch: Adjust to Makefile.am.
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm62
1 files changed, 36 insertions, 26 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 03a12f5f15..2a493fc40b 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -5394,27 +5394,32 @@ faster results and to avoid unnecessary server load.")
(package
(name "upower")
(version "0.99.11")
- (source (origin
- (method url-fetch)
- (uri (string-append "https://upower.freedesktop.org/releases/"
- "upower-" version ".tar.xz"))
- (sha256
- (base32
- "1vxxvmz2cxb1qy6ibszaz5bskqdy9nd9fxspj9fv3gfmrjzzzdb4"))
- (patches (search-patches "upower-builddir.patch"))
- (modules '((guix build utils)))
- (snippet
- '(begin
- ;; Upstream commit
- ;; <https://cgit.freedesktop.org/upower/commit/?id=18457c99b68786cd729b315723d680e6860d9cfa>
- ;; moved 'dbus-1/system.d' from etc/ to share/. However,
- ;; 'dbus-configuration-directory' in (gnu services dbus)
- ;; expects it in etc/. Thus, move it back to its previous
- ;; location.
- (substitute* "src/Makefile.in"
- (("^dbusconfdir =.*$")
- "dbusconfdir = $(sysconfdir)/dbus-1/system.d\n"))
- #t))))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitlab.freedesktop.org/upower/upower")
+ (commit (string-append "UPOWER_"
+ (string-map (match-lambda (#\. #\_)
+ (chr chr))
+ version)))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0frs6ywvsz48d0zfviy40h6mj0icfc1q21hn7p99nchps39z85f8"))
+ (patches (search-patches "upower-builddir.patch"))
+ (modules '((guix build utils)))
+ (snippet
+ '(begin
+ ;; Upstream commit
+ ;; <https://cgit.freedesktop.org/upower/commit/?id=18457c99b68786cd729b315723d680e6860d9cfa>
+ ;; moved 'dbus-1/system.d' from etc/ to share/. However,
+ ;; 'dbus-configuration-directory' in (gnu services dbus)
+ ;; expects it in etc/. Thus, move it back to its previous
+ ;; location.
+ (substitute* "src/Makefile.am"
+ (("^dbusconfdir =.*$")
+ "dbusconfdir = $(sysconfdir)/dbus-1/system.d\n"))
+ #t))))
(build-system glib-or-gtk-build-system)
(arguments
'(#:phases
@@ -5430,10 +5435,15 @@ faster results and to avoid unnecessary server load.")
(assoc-ref %outputs "out")
"/lib/udev/rules.d"))))
(native-inputs
- `(("gobject-introspection" ,gobject-introspection)
- ("pkg-config" ,pkg-config)
+ `(("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("gobject-introspection" ,gobject-introspection)
+ ("gtk-doc" ,gtk-doc)
("intltool" ,intltool)
+ ("libtool" ,libtool)
+ ("pkg-config" ,pkg-config)
("python" ,python)
+ ("which" ,which) ; for ./autogen.sh
;; For tests.
("python-dbus" ,python-dbus)
@@ -5442,9 +5452,9 @@ faster results and to avoid unnecessary server load.")
("umockdev" ,umockdev)
;; For man pages.
- ("libxslt" ,libxslt) ;for 'xsltproc'
- ("libxml2" ,libxml2) ;for 'XML_CATALOG_FILES'
- ("docbook-xsl" ,docbook-xsl)))
+ ("docbook-xsl" ,docbook-xsl)
+ ("libxslt" ,libxslt) ; for 'xsltproc'
+ ("libxml2" ,libxml2))) ; for 'XML_CATALOG_FILES'
(inputs
`(("dbus-glib" ,dbus-glib)
("libgudev" ,libgudev)