summaryrefslogtreecommitdiff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-04-23 21:32:22 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-04-23 21:32:22 -0400
commit87c0d6265ca014da382824996719c0b8fefe3646 (patch)
treec9036e6bfa9c0c6c140f5f69b57faf5422210dbf /gnu/packages/gnome.scm
parent1eb26d0e07ad439c935b324c1ed858f50e9dcccd (diff)
parente12210dc92098d8581cea3007d57dbb6be16bb41 (diff)
downloadguix-patches-87c0d6265ca014da382824996719c0b8fefe3646.tar
guix-patches-87c0d6265ca014da382824996719c0b8fefe3646.tar.gz
Merge remote-tracking branch 'origin/wip-ungrafting' into HEAD
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm17
1 files changed, 1 insertions, 16 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 34f5078581..78a473b348 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -3221,10 +3221,10 @@ the GNOME desktop environment.")
(uri (string-append "mirror://gnome/sources/" name "/"
(version-major+minor version) "/"
name "-" version ".tar.xz"))
+ (patches (search-patches "libcroco-CVE-2020-12825.patch"))
(sha256
(base32
"1m110rbj5d2raxcdp4iz0qp172284945awrsbdlq99ksmqsc4zkn"))))
- (replacement libcroco/fixed)
(build-system gnu-build-system)
(native-inputs
`(("pkg-config" ,pkg-config)))
@@ -3243,21 +3243,6 @@ XML/CSS rendering engine.")
;; LGPLv2.1-only.
(license license:lgpl2.1)))
-(define libcroco/fixed
- (package
- (inherit libcroco)
- (name "libcroco")
- (version "0.6.13")
- (source (origin
- (method url-fetch)
- (uri (string-append "mirror://gnome/sources/" name "/"
- (version-major+minor version) "/"
- name "-" version ".tar.xz"))
- (sha256
- (base32
- "1m110rbj5d2raxcdp4iz0qp172284945awrsbdlq99ksmqsc4zkn"))
- (patches (search-patches "libcroco-CVE-2020-12825.patch"))))))
-
(define-public libgsf
(package
(name "libgsf")