summaryrefslogtreecommitdiff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
authornee <nee.git@cock.li>2017-06-10 16:22:43 +0200
committerKei Kebreau <kei@openmailbox.org>2017-06-11 14:04:57 -0400
commitb6821ee051443f2379162da833776b2bb41d55ab (patch)
treea100200dc616ff2b73a617676cdd3be3c0257ff9 /gnu/packages/gnome.scm
parentf66ea7b8de91ef95a1119e052045668ef67f11a9 (diff)
downloadguix-patches-b6821ee051443f2379162da833776b2bb41d55ab.tar
guix-patches-b6821ee051443f2379162da833776b2bb41d55ab.tar.gz
gnu: Add five-or-more.
* gnu/packages/gnome.scm (five-or-more): New variable. Signed-off-by: Kei Kebreau <kei@openmailbox.org>
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index d3f7344508..a4fc2195cb 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -24,6 +24,7 @@
;;; Copyright © 2016, 2017 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2017 Thomas Danckaert <post@thomasdanckaert.be>
;;; Copyright © 2017 Hartmut Goebel <h.goebel@crazy-compilers.com>
+;;; Copyright © 2017 nee <nee-git@hidamari.blue>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -2449,6 +2450,37 @@ and the GLib main loop, to integrate well with GNOME applications.")
and other secrets. It communicates with the \"Secret Service\" using DBus.")
(license license:lgpl2.1+)))
+(define-public five-or-more
+ (package
+ (name "five-or-more")
+ (version "3.22.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnome/sources/" name "/"
+ (version-major+minor version) "/"
+ name "-" version ".tar.xz"))
+ (sha256
+ (base32
+ "1b26afyjr26wqy5j008gzsi3hpblbmabh0192lx6414lml1qxkxs"))))
+ (build-system glib-or-gtk-build-system)
+ (native-inputs
+ `(("pkg-config" ,pkg-config)
+ ("desktop-file-utils" ,desktop-file-utils)
+ ("intltool" ,intltool)
+ ("itstool" ,itstool)
+ ("xmllint" ,libxml2)))
+ (inputs
+ `(("gtk+" ,gtk+)
+ ("librsvg" ,librsvg)))
+ (home-page "https://wiki.gnome.org/Apps/Five%20or%20more")
+ (synopsis "Logic puzzle game")
+ (description "Five or More is a game where you try to align
+ five or more objects of the same color and shape causing them to disappear.
+ On every turn more objects will appear, until the board is full.
+ Try to last as long as possible.")
+ (license license:gpl2+)))
+
(define-public gnome-mines
(package
(name "gnome-mines")