summaryrefslogtreecommitdiff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
authorKei Kebreau <kei@openmailbox.org>2017-06-08 22:55:24 -0400
committerKei Kebreau <kei@openmailbox.org>2017-06-09 21:03:35 -0400
commit94e10cf4bd384cbda5d8c9dd37a0c13a6e9549f0 (patch)
tree33e316c5098c07b7d8c0e8870a9a5ba879453588 /gnu/packages/gnome.scm
parent8caf5bac4c89512793276054770386c343c73e7b (diff)
downloadguix-patches-94e10cf4bd384cbda5d8c9dd37a0c13a6e9549f0.tar
guix-patches-94e10cf4bd384cbda5d8c9dd37a0c13a6e9549f0.tar.gz
gnu: Add libgxps.
* gnu/packages/gnome.scm (libgxps): New variable.
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 9ea3bb07a5..4667e7455d 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -288,6 +288,38 @@ the GData protocol — most notably, Google's services. It provides APIs to
access the common Google services, and has full asynchronous support.")
(license license:lgpl2.1+)))
+(define-public libgxps
+ (package
+ (name "libgxps")
+ (version "0.2.5")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnome/sources" name "/"
+ (version-major+minor version) "/"
+ name "-" version ".tar.xz"))
+ (sha256
+ (base32
+ "184r06s8g20cfigg7m169n42jjsc9wmzzlycr4g1fxxhr72r8x9y"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("gobject-introspection" ,gobject-introspection)
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("cairo" ,cairo)
+ ("glib" ,glib)
+ ("libarchive" ,libarchive)
+ ("libjpeg" ,libjpeg)
+ ("lcms" ,lcms)
+ ("libtiff" ,libtiff)
+ ("nettle" ,nettle)))
+ (home-page "https://wiki.gnome.org/Projects/libgxps")
+ (synopsis "GObject-based library for handling and rendering XPS documents")
+ (description
+ "libgxps is a GObject-based library for handling and rendering XPS
+documents. This package also contains binaries that can convert XPS documents
+to other formats.")
+ (license license:lgpl2.1+)))
+
(define-public gnome-common
(package
(name "gnome-common")