summaryrefslogtreecommitdiff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-10-06 17:57:23 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2020-10-06 18:06:34 +0200
commit024b273ecc8378a8206fa36052f8de3db600340c (patch)
treedf42d5f1f5f355903ba25c5d22a366c4869227e5 /gnu/packages/gnome.scm
parent7721dbf98330ee5ffcdf8625a8c42132532f4025 (diff)
downloadguix-patches-024b273ecc8378a8206fa36052f8de3db600340c.tar
guix-patches-024b273ecc8378a8206fa36052f8de3db600340c.tar.gz
gnu: gnumeric: Update to 1.12.48.
This brings Python 3 support & fixes building against goffice@0.10.48. * gnu/packages/gnome.scm (gnumeric): Update to 1.12.48. [inputs]: Replace python-2 and python2-gobject with python and python-pygobject, respectively.
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm8
1 files changed, 4 insertions, 4 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 6e4489fa78..9daf41f14d 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -4033,7 +4033,7 @@ Hints specification (EWMH).")
(define-public gnumeric
(package
(name "gnumeric")
- (version "1.12.46")
+ (version "1.12.48")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnome/sources/gnumeric/"
@@ -4041,7 +4041,7 @@ Hints specification (EWMH).")
"gnumeric-" version ".tar.xz"))
(sha256
(base32
- "1qdmw2dp7rmq8fmjapgwaks7ajh270wm6kyvlxlzwbgmg8vngp4z"))))
+ "14556b0vyxdvdwjlin0rv7jk0vq4nplbmvp9j89bhkfk84xf7k2p"))))
(build-system glib-or-gtk-build-system)
(arguments
`(;; The gnumeric developers don't worry much about failing tests.
@@ -4069,8 +4069,8 @@ Hints specification (EWMH).")
("librsvg" ,librsvg)
("libxml2" ,libxml2)
("libxslt" ,libxslt)
- ("python" ,python-2)
- ("python2-pygobject" ,python2-pygobject)
+ ("python" ,python)
+ ("python-pygobject" ,python-pygobject)
("zlib" ,zlib)))
(native-inputs
`(("bison" ,bison)