summaryrefslogtreecommitdiff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-06-28 10:35:43 +0200
committerRicardo Wurmus <rekado@elephly.net>2018-06-29 21:53:55 +0200
commit8839b6beb163b4bbe11018990d16f927f68e9196 (patch)
treef9508e6b2beeb1b021574eeff8bacf7932d50161 /gnu/packages/gnome.scm
parentdbe1bd5dd9ca7a8a52e679f573b409340a2632d6 (diff)
downloadguix-patches-8839b6beb163b4bbe11018990d16f927f68e9196.tar
guix-patches-8839b6beb163b4bbe11018990d16f927f68e9196.tar.gz
gnu: vala: Update to 0.40.7.
* gnu/packages/gnome.scm (vala): Update to 0.40.7. [native-inputs]: Add grep and sed. [inputs]: Add graphviz. [arguments]: Fix PKG_CONFIG_PATH before building tests; remove obsolete configure flag.
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm18
1 files changed, 12 insertions, 6 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 6c7b4ebdce..01df6f15e7 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -121,6 +121,7 @@
#:use-module (gnu packages ssh)
#:use-module (gnu packages xml)
#:use-module (gnu packages gl)
+ #:use-module (gnu packages graphviz)
#:use-module (gnu packages compression)
#:use-module (gnu packages spice)
#:use-module (gnu packages tex)
@@ -2033,7 +2034,7 @@ passwords in the GNOME keyring.")
(define-public vala
(package
(name "vala")
- (version "0.36.3")
+ (version "0.40.7")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnome/sources/" name "/"
@@ -2041,7 +2042,7 @@ passwords in the GNOME keyring.")
name "-" version ".tar.xz"))
(sha256
(base32
- "0706izk9prxqclm7gv4f63diwnlc1llvfl5sc9ghqbgn076lx2mc"))))
+ "1v0ak68lrnbb5lyd48j6sxa35vfrii86zmhxdhkdb85k1bv65rmy"))))
(build-system gnu-build-system)
(arguments
'(#:phases
@@ -2049,20 +2050,25 @@ passwords in the GNOME keyring.")
(add-before 'check 'pre-check
(lambda _
(setenv "CC" "gcc")
+ (substitute* "valadoc/tests/testrunner.sh"
+ (("export PKG_CONFIG_PATH=" m)
+ (string-append m "$PKG_CONFIG_PATH:")))
;; For missing '/etc/machine-id'.
(setenv "DBUS_FATAL_WARNINGS" "0")
- #t)))
- ;; Build the Vala API generator
- #:configure-flags '("--enable-vapigen")))
+ #t)))))
(native-inputs
`(("pkg-config" ,pkg-config)
("flex" ,flex)
("bison" ,bison)
("xsltproc" ,libxslt)
+ ("grep" ,grep)
+ ("sed" ,sed)
("dbus" ,dbus) ; for dbus tests
("gobject-introspection" ,gobject-introspection))) ; for gir tests
+ (inputs
+ `(("graphviz" ,graphviz)))
(propagated-inputs
- `(("glib" ,glib))) ; required by libvala-0.26.pc
+ `(("glib" ,glib))) ; required by libvala-0.40.pc
(home-page "https://live.gnome.org/Vala/")
(synopsis "Compiler for the GObject type system")
(description